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PREFACE 
NORFAC is a Nordic research and development project involving 12 

partners, which later in the project were reduced to 10 partners, 

collaborating to make a low energy facade solution for use in 

renovations of the existing building mass. The focus of the project is 

buildings from the 1960s-1970s that have element-based facades and a 

separate load bearing structure.  

 

The project is funded by Nordic Innovation. 

 
Nordic Innovation 

http://www.nordicinnovation.org 

Nordic Innovation is a Nordic institution working to promote cross-

border trade and innovation. It is working under the Nordic Council of 

Ministers, and is a key player in implementing the Nordic trade, 

industry and innovation partnership programme. 

The aim of this programme is to make the Nordic countries a world-

leading region for innovation and sustainable growth in a cross-border 

cooperation in collaboration between public and private institutions. 

 

VIA University College is responsible for developing a BIM platform for 

the NORFAC project in collaboration with the other project partners. 

The development of the BIM platform is ‘Work Package’ number 5 in 

the NORFAC project, and throughout the report, it will be referred to as 

WP5. 

 

 

 

The project partners are: 

Bjerg Arkitektur A/S (DK) 

ClimaWinTechniq (DK) 

Complete Green Housing (NO) 

Contec (DK) 

Danish Technological Institute (DK) 

Horn Group ApS (DK) 

MT Højgaard A/S (DK) 

Passivhuscentrum (SE) 

Sagawood (DK) 

Sætheren Element (NO) 

Via University College (DK) 

 

  

http://www.nordicinnovation.org/
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INTRODUCTION 

For many reasons then the existing building mass dating from the 1920s 

and forward will be the focus of architects for decades into the future. 

With the challenges that the planet is facing on climate change, then we 

as building professionals have to take upon us the task of renovating and 

energy optimizing the energy consumption of buildings, which in 

Scandinavia is far the biggest consumer of energy. Also with the Planet’s 

limited resources it will make good sense to modernize and optimize 

existing buildings from past decades rather than demolishing them and 

building all new constructions. 

So, from energy- and material consumption perspectives it makes good 

sense to renovate existing buildings. Economically that is not necessarily 

always the case. Building cheap and effective is the aim of any 

construction company as it maximizes the profit.  

The NORFAC project aims to generate conceptual thoughts and test a 

façade solution, that will not only be cheap and effective to use in 

renovation, but also a solution that will: 

 be made of materials that perform well within a Life Circle 

Assessment (LCA) perspective 

 Optimize the energy consumption of the building to, or close to, 

passive house standards by using new technology and intelligent 

building products. 

  strive to be as sustainable as possible – not only regarding 

environmental sustainability, but also social sustainability – e.g. by 

being quick to mount on the facades, so that inhabitants are the 

least possible effected by a renovation project. 

 

 

With regard to the Building Information Modelling (BIM) aspect which 

VIA University College is involved in primarily, then the aim is that the 

BIM-model of the façade system should be designed in a way, so that 

product properties of the various components that the wall panel 

consists of should be filled with data and setup in a way, so that it can 

easily be exported to a PHPP-calculation tool for easy evaluation of the 

façade solution. This will help architects make quick and precise 

predictions of the façade’s performance both in a LCA and an energy 

consumption perspective. 

 

When such a façade system is fully developed then there will be a good 

business potential, as all of the Scandinavian and most North European 

countries have huge amounts of existing buildings from the 1950-1970s 

waiting to be renovated. There is no good reason not to start renovating 

the existing building mass – especially since a renovation cost can be 

covered by what a building owner would have to spend over a period 

anyway for heating/cooling. 
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Notes from WP2 input to WP 5 
 

BIM Concept – Web platform 

 
The Web platform were described in WP 2 where there should be more 

entrances depending on who the user would be.  However, as the 

progress and workshops went along, it turned out to be more 

appropriate with a common entrance and following descriptions: 

There should be following entrance buttons: 

 Home 

 NORFAC ELEMENTS 

 PARTNERS 

 SUSTAINABILITY 

 CONTACT 

 

Moreover it was agreed that the sustainability factors from WP 2should 

be following factors: 

 Model data from BIM model – Revit 

 Element data input from Supplier 

 4D and 5D Parameters 

 Planning, VDC data input 

 Energy parameters - Data input – and energy losses 

 Sustainability parameters in the Revit Object properties  

 

 

 

 

 

 

 

Fig 1 Concept from WP 2 report p. 56 
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Fig 2 BIM concept from WP 2 report p. 63 

 

VIA’s role in the NORFAC  
The part of the NORFAC project that VIA University College is in charge 

of (WP5) is developing a NORFAC platform for the end product of the 

project. A part of this NORFAC platform is a open BIM-platform.  

The purpose of the platform is to let the project partners and potential 

future collaborators work with the façade solution in an BIM 

environment and to be able to share information via this platform. 

BIM (Building Information Modelling) is a term describes a computer 

based modelling technique where information’s about e.g. a complete 

building or parts of a building are stored within the computer model that 

is produced in the design- or projecting phase typically by an architect’s 

office. 

BIM differs from CAD (Computer Aided Design) which initially started 

around 40 years ago as 2D line based production drawings. BIM has 

developed primarily over the last 10 years and it is today 3D models 

which contain project and element properties. These properties can be 

exported to other softwares for e.g. simulations and calculations.  

From an early stage it was intended to make the NORFAC platform as an 

Open BIM platform. Open BIM is a description for BIM in a file-format 

that can be read by all available BIM softwares. The major BIM softwares 

available today are made by a handful of companies, and these do not 

have the best exchange between the softwares. 

A possible Open BIM format could have been the IFC-file format, but 

since its not problem free to work with IFC-formats, then for practical 

reasons the project group has abandoned then the intention of having 

an Open BIM-platform. Instead the NORFAC project collaboration will be 

carried out in Autodesk Revit. It is per definition a closed BIM 

environment. 

A part of the NORFAC platform will be a website (norfac.eu) on which 

both information about the NORFAC end product, the project partners 

and the NORFAC BIM platform will be available. 

 

Openness in NORFAC 

A different take on “Openness” which unlike OpenBIM will be integrated 

in the NORFAC. VIA University College, Bjerg Architecture and 

Passivhuscentrumtrum will contribute to the NORFAC website with 

information about their specific fields of expertice and make this 

knowledge available to the public, so that he website can be used by the 

public and private parties who are interested in sustainable façade 

renovation of 1960s-1970s buildings. 
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Commercial aspects in NORFAC 

The NORFAC platform will as well as the information for the public also 

contain descriptions of the project partners who supply know-how and 

products for the physical façade solution, and therefore have a more 

commercial interest in the NORFAC project.  
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PLATFORM 
Preliminary study to platform - Choise of BIM Platform and 

applications 
 

From an early stage it was intended to make the NORFAC platform as an 

Open BIM platform. Open BIM is a description for BIM in a file-format 

that can be read by all available BIM softwares. The major BIM softwares 

available today are made by a handful of companies, and these do not 

have the best data-exchange between the software’s. 

A possible Open BIM format could have been the IFC-file format, but 

since it is not problem free to work with IFC-formats, then for practical 

reasons the project group, on one of the workshops in the process, 

chose to abandon the initial agenda of having an Open BIM-platform. 

Instead the NORCAD project collaboration will be carried out in 

Autodesk Revit. It is per definition a closed BIM environment. 

 

 

Platform – OpenBIM  
As previously discussed in this report, there are two primary 

approaches for BIM integration: to stay within one software vendor’s 

products (Closed BIM) or to use software from various vendor that can 

exchange data using industry supported standards (open BIM). 

Open BIM is a universal approach to the collaborative design, 

realisation and operation of buildings based on open standards and 

workflows. Open BIM is an initiative of buildingSMART and the central 

file format is the IFC format (Industry Foundation Classes 

 

As a result of previous survey from NORFAC project partners (fig 3), it is 

decided that the chosen BIM platform is a Revit based development  

and in the additional BIM-guide, there will be a guideline concerning 

the approach to the IFC – format. 

 

Fig 3 Project partners´BIM reference  
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Platform – Revit  

During May, June and July 2015 project meetings were held with Bjerg 

and “Ventilationsvinduet” in order to design and define the criteria’s 

for a future NORFAC window family to the platform. 

 

 

Fig 4 Development ”Ventilationsvinduet” 

 

 

 

 

   

 
Fig 5 Process development “Ventilationsvinduet” 
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The above shown figure 4 and 5 shows Examples of presentations used 

in the project meetings with Bjerg and “Ventilationsvinduet” 

The parameters and Revit Properties were discussed under the design 

phase of “Ventilationsvinduet”. 

 

After the initial development for parameters into the Revit family for 

“Ventilationsvinduet” the research went on with Bjerg and other 

NORFAC partners, where the research had a frameset from the 

designed element to be used in FLEX office at Technological Institutes 

in Taastrup 

 
Fig.6 FLEX Office Principle model Concrete - open 

 
Fig.7 FLEX Office Principle model Concrete - closed 

 

 

Fig.8 FLEX Office Principle model Wood - open 
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The data, which were mentioned in WP 2 were, developed and 

automatically a lot of the data input is already in as default features in 

the Revit model 

Parameter data input to the BIM model to be researched and 

developed.  

 

 

 

 

 

 

 

 

 

 

 

Fig 9 Parameter data input to the BIM model to be researched and developed   
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PROPERTIES FOR REVIT OBJECT ELEMENTS 
Modeldata from the BIM model: 
Area, m2. (excl. Windows and doors) model output 
Volume, m3. (excl. Windows and doors) model output 
Length (A), m. (in plane) model output 
Length (B), m. (inserts) model output 
Element data input from Supplier: 
Element number Serial number, QR type data 
Classification (CCS/SfB ) type data 
Code (Sigma, Navisworks etc.) type data 
Weight, kg (kg/m2 (type data) * Area) calculation 
Gt, (location, Climate zone 1, 2 or 3) Scroll menu, preset data 
Existing wall type (U‐value dependence) Scroll menu, preset data 
Supplier(s) (Link to homepage) type data 
Maintenance info (Link to homepage) type data 

 

4D AND 5D BIM PARAMETERS 
Price, data input: 
Kr. / m2 (including… ) type data 
(excluding… ‐ project specific) type data 
Planning, VDC data input: 
Type code, etc. (… ) type data 

 

 

 

 

Fig 10 Model from FLEX office 

Most of the data were discussed in development of the window 

family for “Ventilationsvinduet” but a lot of the data will infuture 

depend on individual input from supplier, including data 

concerning Climate zone (see also fig 11) 
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ENERGY PARAMETERS IN REVIT OBJECT PROPERTIES 
Data input: 
Transmissions loss, W/m2K (U‐value) type data 
Line loss (A), W/mK (Perimeter, terrain) type data 
Line loss (B), W/mK (Perimeter, roof) type data 
Line loss (C), W/mK (inserts, windows etc.) type data 

Airtightness, n50 (…) type data 

 

Model output, energy losses: 
Transmission, kWh/y (U‐value * Area * Gt) calculation 
Line loss, terrain, kWh/y (length (A) * Line loss (A) * Gt) calculation 
Line loss, roof, kWh/y (length (A) * Line loss (B) * Gt) calculation 
Line loss, Windows, kWh/y (length (B) * Line loss (C) * Gt) calculation 
Ventilations loss, n50 (…) calculation 
Total energy loss (sum) calculation 

 

Fig 11 Climate Zone 1-3 in the NORFAC context 

  

1 

2 

3 
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SUSTAINABILITY PARAMETERS IN THE REVIT OBJECT PROPERTIES 
Data input: 
Kg/CO2 equivalent / m2 (Breeam; A1‐A4) type data 
(DGNB; A1‐A3, B1, B4, B6, C3, C4, D) type data 
# material A, % (% of volume pr. m2 element) type data 
# material B, % (% of volume pr. m2 element) type data 
# material C, % (% of volume pr. m2 element) type data 
OR pr. Element type data 
EPD (LINK to certificate) type data 
Wood, % with FSC certf. (% of volume) type data 
(LINK to certificate) type data 

 

Model output, comparison: 
Kg/CO2 equivalent, total (Breeam; …) * Area calculation 
(DGNB; …) * Area calculation 

 

 

 

 

 

 

 

 

 

Fig 12  PHPP calculations were research and developed 

In addition, data parameters in relation to potential PHPP calculation 

were discussed and based on these discussion a later integration by use 

of the tool Dynamo were discussed.  

Dynamo is described in last chapter “PHPP integration with Dynamo” 
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Platform – BIM Objects  

BIMobjects   

As a part of the initial investigations into what the BIM platform In the 

NORFAC project couple be, then the company BIMobjects was studied. 

BIM objects provide a platform for companies to host and display their 

products in various CAD-file format e.g. Revit family-files. To have 

downloadable Revit-families make sense so that users can optimize their 

own work flor by getting a file that is fast to use and reliable as it is 

made by the company itself. 

 

BIM objects provide modelling services for companies who are 

interested in getting their products built in e.g. in Revit-format.  

All of the BIMobjects services cost money on an annual basis – see fig 13 

 

 

Fig. 13 BIM Object price list 2015 

 

During the project period in 2015 BIM Object were researched as a 

potential platform for the NORFAC project. One of the solutions 

“BIMobject Hercules” a cloud solution for large companies to develop, 

organise, structure, standardise and manage their own BIM objects, 

and also publish and syndicate these in a controlled way to project 

groups anywhere in the world.  
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“BIMobject Hercules” provides a cloud-based content management 

solution to support digital construction. It is intended for contracting, 

construction, consultancy and architecture companies to manage and 

control their BIM content in a cloud-based environment, allowing 

thousands of users to share the same BIM content. BIM Object is 

suitable for the chosen closed BIM (Revit) 

Moreover the product from BIM Object has been developed as a 

platform and is an integrated part of the BIMobject Cloud. It enables 

companies to self-manage an extensive range of BIM content including 

documentation, CAD files and BIM objects, and to have a Single Source 

of Truth, version handling, structured data, support for languages and 

various classification systems. 

The platform is scalable with various user roles and cloud apps. Project 

owners can upload their 

own proprietary corporate BIM objects to various Project Clouds, then 

attach different property sets. With user groups, the owner can deploy 

these into the internal organisation or to external design teams for 

example a NORFAC consortium. 

Since NORFAC is a collaboration and meant to be an open and 

accessible platform for other partners in future, BIM Object was seen as 

a possible good and suitable solution in a NORFAC context. Yet in 2015 

the project partners in the NORAC consortium was not yet prepared for 

the economically aspect in this project.  

Therefor BIM Object Cloud solution were recommended by VIA 

concerning W5 BIM Platform on a project meeting in Hönefoss in 2015 

 

 

Fig. 14 BIM Object Solution (www.bimobject.com) 

 

 

 

http://www.bimobject.com/
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BIMobjects was suggested as a part of the NORFAC end product, the 

BIM platform, at the workshop in October 2015 in Hönefoss, Norway. 

At the following workshop in may 2016 in Taastrup, Denmark, the 

project partners decided to investigate the possibilities of making a 

platform that does not include BIMobjects. At this stage the ownership 

of the NORFAC end product is still a bit unclear and on the basis it 

makes sense to go for a low cost/low maintenance solution. 

Ownership and maintenance were discussed briefly at the time, and at 

the time the conclusion was to push any decisions about this into the 

future. 

 

After turning down the idea of a BIMobjects based platform the VIA 

project team – in accordance with the response from the NORFAC 

project participants, to work on a website based web platform – 

possibly sustained by a cloud based storage for the BIM platform. 
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Website - Software of choice - Adobe Muse  
In order to develop the website for the NORFAC platform the VIA project 

team looked at various softwares – both free and commercial software, 

for developing a website. 

After having rejected the BIMobject based suggestion then it will have to 

be a website that can both inform the public about NORFAC and also 

provide the necessary Revit-files, and knowledge about how to use 

these, to the architects/engineers/advisors who will design the NORFAC 

facades for their clients. 

 

At the start of the project the domains norfac.eu and norfac.net were 

purchased and one of these will serve as the location of the NORFAC 

website. Both sites are registered with One.com. 

The reason for venturing into web-design is that it makes sense to 

deliver the BIM-platform on a website as long as the intention of the 

NORFAC project is to generate knowledge for a wider audience than the 

project partners. This makes sense as new project partners will hopefully 

contribute to the NORFAC façade solution in the future – both with 

knowledge and increased business. 

VIA University College has a responsibility for making research projects 

in which staff members participate, available to its students in some 

form – this will be fulfilled by making a website which is publically 

accessible where students can download and work with the NORFAC 

Revit-components. 

The softwares which were tested for website creatation were: 

 

Wordpress 

Wordpress: - free to use, but design choises are limited to which 

“components” or “scripts” that are available from developers – or you 

develop yourself. This limits the degree of freedom in the graphical 

design phase, which is found counter-productive on a commercial 

website.  

One.com website editor 

One.com website editor: - frees to use, but found to be too simple and 

not always reliable based on experience from other websites. 

Adobe Dreamweaver 

Adobe Dreamweaver: - a commercial website developing platform 

favored by many professionals in the website creation business, but – it 

is complicated to use and a website could not easily be maintained by 

someone who is not an experienced user of the software. 

 

Adobe Muse 

Adobe Muse: - a commercial website developing platform from the 

same company as the above. Adobe Muse is however designed so that 

you can operate it when you have skills from other Adobe software – 

e.g. the layout software Indesign. Therefore it would be quite easy to 

find someone who can maintain an existing website without a lot of 

insight in Muse.  

Adobe Muse is chosen by the VIA project group as the software of 

choise for the purpose of developing the website for the NORFAC 

project. 
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Since the VIA project team developed a concept for the NORFAC portal, 

which is “bigger” than a BIM-based solution, which could have been 

limited to work in Autodesk Revit, then a cloud based storage solution 

will be investigated along with the work on the website. 

Dropbox.com will be the cloud based storage solution for the project 

until somebody decides to switch to another solution. 

Openness in NORFAC 

A different take on “Openness” which unlike OpenBIM will be integrated 

in the NORFAC. VIA University College, Bjerg Architecture and 

Passivhuscentrum will contribute to the NORFAC website with 

information about their specific fields of expertise and make this 

knowledge available to the public, so that he website can be used by the 

public and private parties who are interested in sustainable façade 

renovation of 1960s-1970s buildings. 

 

Commercial aspects in NORFAC 

The NORFAC platform will as well as the information for the public also 

contain descriptions of the project partners who supply know-how and 

products for the physical façade solution, and therefore have a more 

commercial interest in the NORFAC project.  

Adobe Dreamweaver: - a commercial website developing platform 

favored by many professionals in the website creation business, but – it 

is complicated to use and a website could not easily be maintained by 

someone who is not an experienced user of the software. 

 

Adobe Muse: - a commercial website developing platform from the 

same company as the above. Adobe Muse is however designed so that 

you can operate it when you have skills from other Adobe software – 

e.g. the layout software Indesign. Therefore it would be quite easy to 

find someone who can maintain an existing website without a lot of 

insight in Muse.  

Adobe Muse is chosen by the VIA project group as the software of 

choise for the purpose of developing the website for the NORFAC 

project. 

 

 

Fig. 15 Adobe Muse were selected as the Web platform editor 

 

In Appendix 1 you will find a manual for use of Adobe muse.  
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PHPP integration with Dynamo 
 

Dynamo as a platform for data exchange. 

The aim of the data exchange program was to retrieve information from 

the Revit-families and export the data to be used in specialized 3rd party 

software. The exported data should be used in an analysis of the 

sustainability and energy efficiency of the façade elements. The 

exchange software should be general and extendable to suit various 

software. 

During the autumn 2015 period it has been examined how to extract 

properties from Revit families (ventilation window, façade elements and 

others).  This might be useful in order to export certain properties to 3rd. 

party software for further calculations or simulations. 

The expected requirement for the software was that it should be very 

user-friendly, as not all suppliers of components may have extended 

Revit knowledge or programming skills. 

A new free graphical programming interface called “Dynamo” has 

evolved based on the Grasshopper plug-in to the 3D modelling software 

Rhinoceros. Dynamo has shown that it does a great job helping architects 

to dynamically develop their concepts. This has been the reason for the 

decision to investigation Dynamo for implementation in the Norfac 

project.. 

Dynamo is preinstalled as part of Revit by default. It can be found in 

various panels according to Revit version. Under Add-ins in versions prior 

to 2017 and under Manage in version 2017 and onwards. 

Dynamo has a fairly limited “Out of the Box” environment and is highly 

depending on 3rd party “Packages”.  The packages are developed by non-

commercial “Open-source” developers and updated frequently. Dynamo 

itself is also updated quite often; actually, they have a “Daily build” 

section on their web-site. This however revealed a potential problem as 

version match turned out to be critical. 

      

 

 

 

 

 

 

Figure 1   Daily versions of Dynamo  

   

 

                      
Figure 

2  

Version mismatch issue            
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This means that it can be a tedious task to match Dynamo and certain 3rd 

party packages. 

However, we tried to build a Dynamo project to exchange data between 

Revit and excel files as we expect that an excel sheet for PHPP should be 

included in the range of target applications. To avoid the package issue 

the built-in functions were tested. Initially they only allow for extracting 

and writing individual cells. To make this more useful, some 

programming skills is needed though.  

Manipulating lists is essential to utilize the built-in functions to their full 

extend. Therefore, we recommend the suppliers to consult 

programmers or CAD-consultants with the required competences.  

Building the script results often in a complex structure, hard to 

understand, even for quite simple tasks. Therefore, it is advisable to 

group and fold a number of code blocks and thereby reduce the 

spaghetti pattern of the programs. Also commenting the groups may 

help keeping a clean structure in the program. 

 Figure 3  Simple read write to excel using built-in functions with some spaghetti 

 

The properties could be of the type “Type” or “Instance” and the way 

these are handled, is different and must be considered. We assume the 

most used properties must of the type “Type” to reduce work overload 

when applying the Revit families. However many of the parameters set 

as instance may be calculated by the Revit software itself.    

As a conclusion to this preliminary test, it can be stated, that the Dynamo 

programming interface has potential to automate the retrieval of data 

from the Norfac elements and export to at least excel sheets. As from 

excel sheets it should be a trivial issue to import into various databases 

for further analysis. 
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When it comes to the user friendliness of Dynamo, it is concluded that 

the huge amount of updates and patches of Dynamo itself and the 

version dependency of the 3rd part packages will be an obstacle for the 

average user. Programmers or enthusiasts will have more options using 

the software. 

However comparing to API and C#, programming with Dynamo is by far 

the less complex. 

The supplied Dynamo script includes the template for extraction of 

parameters for both type and instance parameters and a “yes/No” 

parameter to separate the families from which the information should 

be included. 

The only information needed to run the script apart from the family-

parameters is the file path to the Excel-file to hold the data. 

The Norfac script consists of a number of small scripts for each Revit 

category and each of these scripts can easily be modified to suit the 

user’s need. All of the script has been developed, using only native 

Dynamo nodes, so it will run on any version of Revit and Dynamo. 

The Norfac Dynamo script has an opening screen, which is very clean and 

simple to use. Just the path to the excel file, need to be entered.  

 

   Figure 4 The clean Norfac Dynamo interface   

 

 

The node “Norfac_2017_1.3.2_PHHPExport” contains the individual 

scripts for the categories. This is the node which needs to be modified to 

include further categories to the data extraction.  
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Figure 5 The Norfac Dynamo nodes for the categories. 

 

Each of these nodes consist of basic Dynamo nodes to extract the values 

from the Revit families and send them to the selected excel file.  

 

 

 

 

 

 

 

 

  Figure 6  The interior of a Norfac basic node. 

The Norfac Dynamo project has been made available to the public 

through the Norfac web site. It can be downloaded together with user 

manual, installation instructions and an instruction video.   

 

THE USER MANUAL FOR VAN BE DOWNLOADED ON: 

http://norfac.net/assets/norfac_dynamo_manual.pdf 

 

 

 

http://norfac.net/assets/norfac_dynamo_manual.pdf
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Appendix 1  
User Manual for Adobe Muse. 
The material is under the Creative Common with following rights: 

 

 

 

Appendix 2 
User Manual for PHPP integration with Dynamo 
The material is under the Creative Common with following rights: 
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VIA UNIVERSITY COLLEGE 
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Chapter 1 – Installing Software – Master page – State Buttons 
 

 
Installing the software and setting up the sample project 

Building a site  map 

Editing  the A-Master page 

Setting the color palette and renaming swatches in the Swatches panel 

Working with elements set  to  100% width 

Working with State Buttons and placed Photoshop Buttons 

Setting the Stroke options of a rectangle to create    lines 

 
 

In this tutorial, you'll familiarize yourself with the Adobe Muse workspace and see how to build a full featured website without writing any code. Part        

1 of Building your first website with Adobe Muse includes instructions to help you get started with Muse. You'll learn how to work with master         

pages,  widgets, placed images,  and links. As you work through this tutorial  you can see what the finished site will look like  at any time by      

reviewing  the Katie's Cafe live  website. 

 
  

Installing the software and setting up the sample  project 

 

1. Download and install the latest version of Adobe Muse    CC. 

2. Download the sample files (ZIP,  78MB). 

3. Uncompress the ZIP file and save the folder named Katies Café Building v3 to your desktop. 

4. Launch Muse. The Welcome screen  appears. Choose File > New    Site. 

5. Choose Adobe Muse CC > Preferences. In the General section, select the desired color theme for the workspace and then click OK (see 

Figure 1). 

Figure 1. Click one of the gray color swatches to set the color theme of Adobe Muse. 

 
 

 
The New Site dialog box appears. You’ll use this interface to edit the settings that are applied to the entire site. 

6. Set the number of Columns to 9.  In the Margins section, set the top and bottom margins to 0 while the fields are unlinked. Set the left and   right 

margins to 4. In the Padding section, set the top and bottom padding to 0. Set the Page Width to 960 and the Min Height to 872 (see Figure 2). 

http://www.katiesbakerycafe.com/
http://www.adobe.com/products/muse.html
http://muse.adobe.com/assets/katies-caf%c3%a9-building-v3.zip
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Figure 2. Update the number of columns in the New Site dialog box. 

 
Note: Use the Resolution menu to choose between Standard and HiDPI (2x) options. This setting allows you to define the quality of assets output  

when you publish or export a Muse site. For more information,  see    Creating High Resolution  Websites. 

 
 

In this tutorial, you'll learn how to make your first website in Muse for desktop computers. Keep the Initial Layout menu set to Desktop, as it is by default. 

Note that if you want to build a website with alternate layouts for smartphones and tablets, you can use this menu to choose which layout    you want to 

design  first. 

The option labeled Sticky Footers is enabled by default. It causes the footer to remain in the desired location, even if the browser window is 

significantly larger than the web page design, as it is on an Apple cinema display (see Figure 3). 

Figure 3. The Sticky Footers option is    enabled by default. 

 
 

 
When the Sticky Footers option is enabled, the footer content remains flush with the bottom of the browser window, regardless of the resolution    

and dimensions of the visitor's desktop monitor (see Figure    4). 
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Figure 4. A zoomed out live site with Sticky Footers enabled (left) compared to a site without Sticky Footers enabled (right). 

 
 

 
For this sample site project—and in most cases—you'll keep the Sticky Footers option enabled in the New Site dialog box. 

7. Click OK to save your changes and close the New Site dialog box. 

8. Choose File > Save Site. In the Save Adobe Muse File As dialog box, enter a name for the site: katiesCafe.muse. Navigate to the location 

where you want to save this sample project (such as the katiesCafe folder on your desktop) and click Save. 

Note: The katiesCafe sample files folder contains a finished version of the sample project named katiescafe-final.muse. If you'd like, you can double-

click the final version of the .muse file to open it after you save your version of the project as katiesCafe.muse. Adobe Muse allows you to   open 

multiple site projects at once, so you can review the katiescafe-final file and use it as a reference as you follow along with these instructions. 

In the next section, you'll begin adding new pages    to the site. 

 

 

Building a site map 

 

A site map is a structured list of the pages that exist in a website's hierarchy. You can create pages that are on the same level (no sub-pages) or       

you can create site maps that contain different tiers of pages. (For example, a larger site could have an About page that contains two subpages    

named Our Mission and Our Staff.) Muse makes it easy to create and rearrange the pages into any order you prefer, and you never have to worry 

about broken links. However, it is important to spend some time organizing the content of a new site, defining which pages are needed, and       

deciding how to present the site's information. In a real-world project, it is part of the pre-planning phase to finalize the different site sections and  

choose the order of the pages. For more information, see Creating a Site Map. 

After closing the New Site dialog box, you are automatically redirected to the Plan view in Muse. By default, all new sites contain one web page 

(named Home) that is linked to one master page (named A-Master). You can rename both of these pages as desired. 

To create a consistent experience, you’ll place repeating site items, such as the header, footer, and site navigation, on master pages. Using this 

strategy, you’ll only need to add the unique content to the individual pages as you build out the site design. 

This sample project is a smaller site that contains a total of five pages, including the Home page. Follow the steps below to add new pages: 

1. Hover over the Home page thumbnail and click the plus (+) icon to the right of the Home page thumbnail, to create another page at the 

same level as the first one. Click the label field below the new page and name it: food. 

When you click the plus (+) sign icon below a page thumbnail, you create a sub-level page to expand a section with pages that relate to a 

specific topic. 

2. Click the plus (+) sign icon to the right of the food page thumbnail to make another new page. Click the label and rename the page: events.   

Click the plus (+) sign icon to the right of the events page thumbnail, to create a new page. Name the new page: about. Repeat this       

operation again, to create one more new page on the same level as the Home page, and name it: visit. 

At this point, the site map has a total of five pages named Home, food, events, about, and visit (see Figure 5). 
 

Figure 5. Create a total of five pages in the    site map. 

 
Note:  This sample site contains five pages on the same level. However, you can create sub-level pages to organize the pages as desired. Sub- 
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level pages are often used to create different sections of the site. If you create more than one master page, you can right-click (Control-click) on        

the page thumbnails in Plan mode to link them to a specific master page. When you first create a new site, the pages link to the A-Master master   

page automatically. 

 
 

Plan mode provides the tools to structure a site and build the site map. If you’d like to change the site’s organization, you can adjust the 

arrangement of pages by dragging page thumbnails in the    site map. 

3. Hover over the GALLERY page thumbnail and then click the plus (+) sign below it. Click the field of the new child page and name it: Gallery- 

fullscreen (see  Figure 6). 

Figure 6. Add a new sublevel page to the site map for the Gallery section. 

 
 

 
After making these changes, the site map is    complete. 

At the top of the Plan view interface, notice that there are three layout buttons for Desktop, Tablet, and Phone layouts. In this sample project, you'll    

only be creating a desktop  design to deliver the site to computer screens. The Tablet and Phone layouts display a plus (+) sign next to their         

names, indicating that they have not yet been created (see    Figure 7). 

Figure 7. Layout buttons let you create and jump between three alternate layouts for the site. 

 

 
In addition to clicking a layout button to jump between site layouts, you can also use keyboard shortcuts to toggle between site plans once you  

have more than one  layout: 

Press Command+7 (Mac) or Control+7 (Windows) to jump to the Desktop site map. 

Press Command+8 (Mac) or Control+8 (Windows) to jump to the Tablet site map, or 

Press Command+9 (Mac) or Control+9  (Windows)  to jump to the Phone site   map. 

These keyboard shortcuts are only active in site projects that contain at least two Desktop, Tablet and/or Phone layouts. 

You'll continue to create the Desktop layout by following along with the rest of this article. To learn more about designing websites for tablets and 

mobile devices, read Creating mobile layout designs in   Muse. 

In the next section, you’ll learn how to edit the A-Master page to add the shared site elements, including the footer content. 

 

 
 

Editing the A-Master page 

 

Begin designing the first master page for the site by adding the artwork that will display on all the linked pages in the site. 

While you can use Muse like a design tool, behind the scenes it generates industry-standard HTML, JavaScript, and CSS to create web pages.  

When you choose to apply styling (such as rounded-corners and gradient fill colors), Muse doesn’t create a vector shape or a grid of pixels. The 

published .muse project is a fully functional website. You'll start by updating the background color of the master page. 

 
 

1. In Plan mode, double-click the field below the A-Master page thumbnail and rename the master page: Footer. Then, double-click the A- 

http://idiom-q-win-1/muse/using/creating-website-mobile-devices.html
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Master page thumbnail to open it in Design mode. The master page opens in its own tab along the top of the workspace (see Figure 8). 
 

Figure 8. The A-Master page is ready  to edit in Design    mode. 

 
 

 
The Selection Indicator is located in the upper left corner of the Control panel. When nothing else is selected, the Selection Indicator displays the  

word Page, meaning only the page itself is selected. If you select an object on the page, such as a rectangle, the word Rectangle is displayed. 

As you work, pay attention to the Selection Indicator to verify you've selected the element you want to edit. If other page elements are selected,    

you can always re-select the entire page by clicking the gray area on either side of the page. 

While the page is selected, you can use the menus in the Control panel to update the fill color and stroke settings. By default, the page fill is set         

to no color and the page stroke is set to 0. For this design, leave the default settings. 

2. Click the Browser Fill link to set the background color or image for the browser window that displays outside the page area. 

3. For this page design, set the browser fill color to a specific color, by entering the hexadecimal value in the field: #F5F1EE (see Figure 9). 
 

Figure 9. Update the color swatch in the Browser    Fill menu. 

 
 

 
4. Click anywhere outside the Browser Fill menu to close   it. 

 

 

Setting the color palette and renaming swatches in the Swatches  panel 
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To make it easy to apply the same color later to other elements of the site, you can add and rename color swatches. This also allows you to 

change a named color swatch to update all instances of that color used in the site. 

1. Open  the Swatches panel  (Window > Swatches). 

2. Choose File > Place. Browse to select the file in the sample files folder named: color-palette.png. Click once anywhere on the page to place     

the image. 

3. Right-click on the Swatches panel and choose Delete All Unused (see Figure 10) 
 

Figure 10. Select the option to delete all the unused colors in the site. 

 
 
 

 
Renaming colors 

 
 

The colors primarily used in the site design are now displayed, along with the generic 50% gray, white, and black color swatches. Next, you’ll 

rename the colors. 

1. Double-click the brown color chip swatch on the far right side. The Swatch Options dialog box opens to display the attributes of the color. In 

addition to specifying a different color value for the swatch, you can update the Swatch Options to name the swatch color descriptively. 

2. Deselect the Name with Color Value checkbox and enter a new name in the Swatch Name field: Dark Brown (see Figure 11). 
 

Figure 11. Assign  a descriptive name  to the color  swatch. 

 

 
3. Click OK to close the Swatch Options dialog   box. 

4. Repeat steps 1-3 to rename the second color swatch from the right. Name it: Off White. 
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5. Rename the remaining two colors, moving from right to left: Light Brown and Brown. 

6. Select the placed image (color-palette.png) and press Delete/Backspace to delete it. 

Next, you'll create the footer that will appear on all    of the pages. 

 

Working with elements set to 100% width 

 

Items that are set as 100% width fill the browser horizontally, no matter how wide the visitor's browser window is resized. If you set a page element       to 

also align with the top and bottom edge of the browser window, an object filled with a solid color or tiled asset will also expand to fit the available space. 

1. Draw a rectangle with the Rectangle tool that spans the width of the page and is about 250 pixels high, near the bottom of the page. 

2. While the rectangle is selected, use the Fill menu to set the rectangle’s fill color to Dark Brown and set its stroke width to 0. You can tell      

when the rectangle is selected, because a blue bounding box with handles appears around its edges and the Selection Indicator in the top    

left corner displays the word Rectangle (see Figure   12). 

Figure 12. Drag the handles on the sides of the rectangle to resize it. 

 
 

 
3. Use the Selection tool to move the rectangle into position. You should briefly see a red border highlighting the left, bottom, and right sides of     

the browser window. This red border indicates that the rectangle is set to display at 100% width. 

Note:  If you prefer, you can also open the Transform panel (Window > Transform) and click the 100% width button. 

 

 
4. If you want to view the site design without the guide overlay, choose View > Hide Guides. You can also use the View Options menu in the 

Control panel to hide and show the   guides. 

 

Working with State Buttons and placed Photoshop Buttons 

 

State Buttons are page elements you can drag and drop from the Widgets Library. They provide a convenient container to create rollover buttons.    

One benefit of using State Buttons is that all of the elements inside will change states at the same time, based on the visitor’s interaction. Add text 

frames, images, rectangles, placed graphics and Photoshop buttons to create custom buttons that fit a site’s design. 

1. Open the Widgets Library (Window >Widget Library). Click Buttons category to expand it. 

2. Select the State Button widget and drag it to the   page. 

3. Click Preview to see a preview of the page. Use your cursor to roll over and click the default button. 

The State Button contains a gray dot and a text frame with the words Lorem Ipsum as placeholder content. Although each of these elements has   

their own states, they respond in unison when you roll over the States Button or click on it. If you manually create a button containing different 

elements, only the text or only the gray dot might respond to the visitor’s mouse movements, depending where the visitor positions their cursor. 

1. Click Design to continue editing the  page. 

2. Select the gray dot to the left of the placeholder text and press Delete/Backspace to delete it. 
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3. Choose File > Place Photoshop button and then browse to select the file named banner.psd in the Assets folder. Leave all the default 

settings in the Import Photoshop Options dialog box that appears and click OK (See Figure 13). 

Figure 13. The dialog box displays the layers in the Photoshop file and State menus let you choose which layer will be displayed for each state of      

the button. 

 
 

 
7. Click once inside the State Button to place the    Photoshop file. 

8. While the placed graphic is still selected, right-click and choose Arrange > Send to Back (see Figure 14). 
 

Figure 14. Rearrange  the Photoshop banner image  to display behind  the text  frame. 

 

 
9. Select the Lorem Ipsum placeholder text with the Text tool and type: DOWNLOAD MENU. 

10. While the text is selected, update the text color in the Control panel or in the Text panel to Off White. Use the Font menu to choose the first 

option: Add Web Fonts. In the interface that appears, search for and choose Open Sans Condensed Bold to format the text. 

 

 
Note: Note: Open Sans Condensed Bold is a web font that you can download by choosing Add Web Fonts from the Font menu. To learn more  

about working with web fonts, read Typography in Muse: Using web fonts, web safe fonts, and system fonts. 

http://helpx.adobe.com/muse/using/typography.html
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11. Set the font size to 15 and choose the centered alignment. Set the tracking to 0 and the leading to 24 pixels. Leave the default link style. In      

the Paragraph-Level Tag menu, choose Subhead  (h2) to improve the site’s search  engine  optimization (see Figure    15). 

Figure 15. Update formatting styles with the options in the Text panel. 

 
 

 
Look in the States panel to see that all four states of the text frame are identical. That is the look of this design. However, you can update the 

colors of the text for different states, if   desired. 

12. Use the Selection tool to drag the side handles of the text frame to make it wider, so that the text does not wrap. Drag the text frame 

horizontally until it is centered within the State Button. A dark blue vertical guide briefly displays when the text frame is centered inside the  

State Button. 

13. Press Escape once to select the entire  State  Button. 

14. Open the States panel (Window > States) to see the appearance of the four states: Normal, Rollover, Mouse Down, and Active. The Normal  

state is selected. This panel enables you to edit the various ways the button’s graphic is displayed, depending on the activity of the visitor’s 

cursor. 

15. Use the Fill menu to set the fill color of the State Button to none. 

16. Repeat steps 14-15 to set the fill color of all states to none. 

17. Use the Selection tool to position the State Button near the top of the brown rectangle, using the alignment guides to center it vertically on     

the page (see Figure  16). 

Figure 16. Center  the customized State Button in top of the footer    area. 

 
 

 

Setting the Stroke options of a rectangle to create lines 

 

To add some visual detail, you’ll create a line and then duplicate    it. 

1. Use the Rectangle tool to draw a rectangle to the left of the State Button that is approximately 377 pixels wide and 15 pixels tall. A tooltip 

displays the dimensions of the rectangle as you draw   it. 
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2. Set the fill color to none and the stroke color to Off White. 

3. Click the word Stroke in the Control panel to open the Stroke Options. 

4. Keep the default alignment setting: Align Stroke to Center. Click the Link icon to allow different stroke widths for each side of the rectangle.     

Set the bottom, left, and right stroke widths to 0, so that only the top has a stroke width of 1 (see Figure 17). 

Figure 17. Update the stroke option settings to only display a stroke on the top of the rectangle. 

 
 

 
5. Click anywhere else on the page to close the Stroke Options dialog box. 

6. Use the Selection tool to position the rectangle so that it is to the left of the State Button and the top edge is centered horizontally. 

7. Option/Alt-drag the rectangle to duplicate the rectangle. Position it on the right side of the State Button (see Figure 18). 
 

Figure 18. Horizontally align the two rectangles with each other and the State Button. 

 
 

 
Continue reading this tutorial. In the next chapter, you'll learn how to work with Menu widgets. Widgets enable you to quickly add advanced 

functionality to pages without writing any code. You'll see how to edit the behavior and appearance of widgets, to customize how they are 

displayed in the site  design. 

 
 

 Twitter™ and Facebook posts are not covered under the terms of Creative Commons. 
 

Legal Notices   |   Online Privacy Policy 

http://help.adobe.com/en_US/legalnotices/index.html
http://helpx.adobe.com/go/gffooter_online_privacy_policy


11 

 

 

Chapter 2 – Menu Widgets – Adding Links etc. 
 

 

Working with Menu  Widgets 

Creating and applying paragraph styles 

Adding Font Awesome Brand Icons to a page 

Adding  links to  downloadable files 

Adding links to external websites 

Creating email links 

Using guides to define the header and footer regions of a page 

Setting page elements as footer   items 

Adding an anchor to the top of the   page 

 

 
In Chapter 1 of Building your first website with Muse, you created a new site, used Plan mode to create the site pages, and then edited the master   

page in Design mode to add page elements to the footer. In this part, you'll learn how to add and customize widgets. The first type of widget you'll      

add is called a Menu widget, which will help visitors navigate to the pages in the site. You’ll also learn about the different types of links you can          

add in Adobe  Muse. 

 
  

Working with Menu Widgets 

 

The footer of master pages typically includes site navigation, so you'll add that next. 

1. Open the Widgets Library by choosing  Window > Widgets   Library. 

2. In the Widgets Library, click the Menus section to expand it. Select the Horizontal widget and drag it from the panel to the footer area of the A-

Master page  (see  Figure 19). 

Figure 19. The Horizontal widget displays the default style when you drag it onto a page. 

 
 

 
The black panel that appears whenever you drag a widget from the Widgets Library is called the Options panel. Click away from the panel to close       

it. You can click the blue arrow    button whenever you want to access it again. 

3. Use the Selection tool to position the Menu widget below the State Button, centered vertically. 

The menu automatically displays the names of the pages that you created, in the same order they appear in the site map. The names of the 
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pages are automatically linked to the pages and they update dynamically. If you later rename or move the pages in Plan mode, Menu widgets 

update and the menu links continue to work as   expected. 

Although each type of widget provides different functionality, many of the concepts you'll use when working with widgets are the same. Locate the 

widget that you want to use in the Widgets Library and then drag it out onto the page. Each widget contains a hierarchy of nested widget         

elements. After selecting a widget, you can continue clicking to drill down to its sub-elements. As you select sub-elements, the Selection Indicator       

in the top left corner displays the name of the element that is currently selected. 

For example, when you first click the widget, the widget itself is selected. If you click again, you select a sub-element, such as a container, and   then 

click again to select the text frame inside a container. To work your way back out of the selected sub-element, press the Escape key. You     can also 

click on the page anywhere outside of the widget area to deselect it. 

While the entire widget is selected, you can reposition it. You can drag its transform handles to scale or resize the dimensions of the entire widget.     

You can set the fill and stroke color, as well as applying styles to control the appearance of the entire widget. 

 
 
 

Configuring and customizing widgets 

 
 

To configure widgets, update the settings in the Options panel. The Options panel is contextual and lets you apply changes to update settings that     are 

specific to that entire widget, or the selected sub-element of the widget. Some widgets have more options than others. The Options panel lets      you 

control how widgets behave as well as how their content is    displayed. 

While a container element is selected, such as a menu item, you can style the widget by setting the Fill and Stroke options. When text labels are 

selected, you can use the Text panel or the text options in the Control panel to style the text. Sometimes you’ll edit the text labels in widgets ― 

although unless you set Menu widgets to the Manual Menu Type, the page names are already set up for you based on the pages in the site map. 

1. Click the Menu widget once and notice that the Selection Indicator displays the word: Menu. Click the blue arrow button to access the 

Options panel (see Figure  20). 

Figure 20. Open the Options panel to configure the    widget's  settings. 

 
 

 
Ensure that the following default options are set, as shown in Figure 22: 

Menu Type: Top  Level Pages 

Direction: Horizontal 

Edit Together: Enabled 

Item Size: Uniform  Size 

Show Left Icon:  Disabled 

Show  Label: Enabled 

Show  Right Icon: Submenus Only 

Parts  Positioning:  Horizontally; Center-Aligned 

 

 
The Options menu settings enable you to configure how the menu will behave. 

2. Click anywhere else on the page to close the Options    menu. 

Next, you'll learn how to edit the appearance of the buttons in the menu, and how to control the text formatting to match the site's design. 

 
 
 

Understanding button states 
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1. Choose File > Preview Site in Browser to preview the site and test the Menu widget.. 

2. Look at the buttons in the menu when the page first loads (this state is called the Normal state). Hover your cursor over the buttons to see      

the Rollover state appear. When you click a button, the corresponding page loads and the button displays with a darker gray color, which is    

the default Active state. The Active state indicates the currently selected page as visitors navigate a site. 

Note: If you click and hold down the mouse button, there’s one additional state, Mouse Down, which displays a custom appearance when the 

visitor clicks  the button. 

 
 
 

Editing button states 

 
 

Next, you'll see how to edit the states of a   button. 

1. Close the browser and return to Adobe   Muse. 

2. Click the widget once to select the entire menu. Click the food button once again, to select the food menu item (see Figure 23). If you 

accidentally click a third time and the Selection Indicator displays the word Label, press Escape once to jump up one level in the hierarchy,      

so that the word Menu Item is   displayed. 

Note: If you accidentally click a third time and the Selection Indicator displays the word Label, press Escape once to jump up one level in the 

hierarchy, so that Selection Indicator displays the word Menu  Item    again. 

 
 

Since the option to Edit Together is enabled in the Options panel, any changes that you make to the appearance of a menu item are applied to all       the 

rest of the buttons in the Menu widget. This makes editing much faster. Unless you need to apply different styling to each button, keep the Edit Together  

option enabled. 

3. Open the States panel by selecting its tab or choosing Window > States. 

The gray buttons define the appearance of each state (see    Figure 21). 

Figure 21. Use the States panel to choose the different states and edit their appearance. 

 
 

 
4. In the States panel, click each item in the list: Normal, Rollover, Mouse Down and Active states. Notice that as you click each state in the 

panel, the Menu widget on the page updates to display the state’s appearance. 

5. Click the Normal state. While the HOME menu item is selected, use the Fill menu to set the fill color to none. When you set the fill color for      

the HOME button, all of the menu items update their Normal state because the Edit Together option is enabled. 

6. Click the Rollover state in the States panel and set the Fill color to none. Repeat this process two more times to set the fill color of the 

Mouse Down and Active states to none. This removes the background fill color to create transparent buttons. 

Later when you make your own sites, experiment with setting a fill color for the entire widget and then setting a different fill color for the menu 

items. You can also add background images to fill menu    items. 

Next you’ll update the appearance of the button labels using a similar editing    process. 

 
 
 

Editing labels of a Menu widget 

 
 

Follow these steps to update the formatting of the text labels that display the page names in each menu item. 

1. While the HOME menu item is selected, click the button again to select the text inside the button. The word Label is displayed in the 

Selection Indicator. 

2. In the States panel, make sure that the Normal state is selected. 
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3. Open the Text panel by clicking its tab or choosing Window > Text. 

4. Update the text using the Text menu in the Control panel or the Text panel. Set the color to Off White. In the Font menu, choose the first      

option: Add Web Fonts. In the interface that appears, search for and select the Open Sans web font to add it. Then, choose it from the list of  

fonts to apply it. 

To learn more about working with web fonts, read Typography in Muse: Using web fonts, web safe fonts, and system fonts. 

5. Set the font size to 12 and use the centered alignment. Set the tracking to 1 and the leading to 120% (see Figure 22): 
 

Figure 22. Set the options in the Text menu to update the appearance of the menu label. 

 
 

Creating and applying paragraph styles 

 

1. Open the Paragraph Styles  panel by clicking its tab or choosing  Window > Paragraph    Styles. 

2. Click the New Style button (page icon) at the bottom of the panel to save this set of font styles, making it easy to apply them to other text 

elements later. 

3. Double-click on the new style you just created in the Paragraph Styles panel, which has been given the default name of Paragraph Style. 

Rename it to menu footer (see Figure 23). 

Figure 23. Click the New Style (page icon) to add a new Paragraph style, and then double-click the new style and enter a descriptive name in the   

Style  Name field. 

 

Note: Right-click (or Control-click) on the name of a style in the Paragraph Styles panel to see a menu appear that enables you to duplicate, delete, 

or unlink styles. You can also choose Style Options from the menu, instead of double-clicking the style name, to access the Paragraph  Style Options. 

 
 

Notice that the Style Options window includes the ability to apply a style to a specific HTML tag. 

If you look at the States panel, you'll notice that all states: Normal, Rollover, Mouse Down, and Active, all use the same font formatting for the  menu 

item labels. 

1. Click Preview to view the design as it will appear in a browser. Muse uses a version of Webkit to display the page, which is used by many 

http://helpx.adobe.com/muse/using/typography.html
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modern web browsers. As you interact with the menu, notice that the buttons only display their labels (the menu item containers are 

transparent). Also note that the labels do not change when you hover your cursor or click on the buttons in the menu. 

2. After testing the menu, click Design to continue editing the A-Master page. 

 

Adding Font Awesome Brand Icons to a page 

 

Instead of adding placed images that take longer to load and are more time-consuming to create and edit, you can drag and drop Font Awesome 

elements on the page. These elements are similar to web fonts. You add font elements, which include many common icons. To update them, use     the 

settings in the Control panel or Text panel the same way you style text frames. 

1. In a browser, visit the Font Awesome widget in the Adobe Muse Add-On Library. 

2. Click the Download button to download the compressed Font Awesome extension (in the .mulib file extension) to your desktop. Do not 

expand the downloaded  file. 

3. Open the Library Panel (Window >   Library). 

4. Click the Import button and then browse to select the .mulib file you downloaded in step 2. 

5. The FontAwesome (icons) Library item is listed in the Library panel (see Figure 24). 
 

Figure 24. After importing Library items they are listed in the panel, ready to use. 

 
 

 
6. Click the arrow to expand the folder of FontAwesome    icons. 

7. Drag a Brand Icons item to the page in the    footer area. 

8. Click the blue arrow button to open the Options panel and choose the Facebook option from the menu. 

You may see a progress bar display as the icon loads in Design view. This occurs because the icons are hosted on a different server just like web  

fonts. 

9. In the Control panel, set the fill color to Brown. In the Text panel, set the font color to Off White (see Figure 25). 
 

Figure 25. Update the appearance of the Facebook icon by setting the fill and text color. 

 
 

 
10. Repeat steps 7-9 to create 4 more icons for Google+, Tumblr, and Twitter. Use the Selection tool to align them horizontally (see Figure 26). 

https://creative.adobe.com/addons/products/1841
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Figure 26. Align the set of four social network icons in a row, using the smart guides to space them evenly. 

 
 

 
11. Select all of the social network icons and choose Object > Group to group them into a set. Drag the group on the page until it is centered 

vertically below the Download Menu button and the Menu    widget. 

 

Adding links to downloadable files 

 

Many restaurant sites post their menu online in PDF format so that visitors can save a copy to their desktop or print it out. 

1. Select the State Button  widget. 

2. Use the Hyperlinks menu in the Control panel to choose the item in the Files section at the very bottom of the menu, Link to File. In the       

Import dialog box that appears, browse to select the file named Katie's Cafe Menu.pdf in the sample files folder. Click Open to select it (see 

Figure 27). 

Figure 27. Browse to select the PDF version of the    menu. 

 
 

 
When you use the Link to File feature, the file is uploaded when the site is published or included in the site folder when the site is exported. It is a    

best practice to copy all of the files for the site into the site's local folder. 

If you look in the Assets panel, you'll see that the KatiesCafeMenu.pdf file is now listed as one of the site's assets. 

3. Choose File > Preview Page in   Browser. 

4. Click the Download Menu link    and see how the linked PDF file displays. 

Depending on the browser you are using, some browsers will display the PDF in the browser window while others will simply download the PDF file       

to your desktop. 

 

Adding links to external websites 
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You can add absolute links to other web pages outside your site. Follow these steps to add external links to each of the social network icons. 

1. Select the Facebook icon and then type (or copy/paste) the link to the Katie's Cafe Facebook page in the Hyperlink menu field: 

http://www.facebook.com/KatiesCafeSF 

2. Select the Google+ icon and enter the link to the Katie's Cafe page on Google+:       https://plus.google.com/u/1/117800212967830061444/posts 

3. Select the Tumblr icon and enter the link to the Katie's Cafe blog on Tumblr: http://katiessf.tumblr.com 

4. Select the Twitter icon and enter the link to the Katie's Cafe page on Twitter: http://twitter.com/katiescafesf 

5. Click the Facebook icon again to select it. Click the blue underlined word Hyperlinks in the Control panel. In the dialog box that appears, 

check the option: Open the link in a new window or tab. Also enter a tooltip in the Tooltip field (see Figure 28). 

Figure 28. Enable the checkbox to open the link in a new window or tab. 

 
 

 
6. Repeat step 5 to set the Google+, Tumblr and Twitter links to open in a new browser window. Enter tooltips for each link (which appear 

when a visitor hovers over the social icon   buttons). 

This is a common web design convention—links that go to other pages of the same site open in the same browser window (which is the default in 

Adobe Muse) and links to pages in other, external websites typically open in a new browser window or tab. 

 

Creating email links 

 

This sample site uses the Simple Contact Form widget to allow visitors to send messages. Later in this article, you’ll learn how to add a contact   

form to the Contact  page. 

If desired, you can add email links (which, when clicked, cause the visitor's email client to open with a new message that displays the email 

address in the To  field). 

Enter the email address with the mailto: prefix in the Hyperlink menu, like this: 

mailto:email@address.com 

Sometimes the list of links in the Hyperlinks menu can become long on larger websites. To find a specific page, anchor link, linked file, or external  

URL, you can quickly filter the list by typing the first few letters of the link in the Links menu field to see the matching items display. 

 

Using guides to define the header and footer regions of a  page 

 

When you design individual pages, they are often varying heights, based on the content added to each page. Muse lets you set up regions so that     

the header content displays at the top and the footer content displays directly below the page content, regardless of each page's height. 

Follow these steps to show the guides and set up the page areas: 

1. To display the header and footer guides, choose View > Show Header and Footer. Alternatively, you can use the View menu in the Control    

panel to enable the Header and Footer guides. When they are showing, a checkbox displays next to the Header and Footer item (see Figure    

29). 

http://www.facebook.com/KatiesCafeSF
https://plus.google.com/u/1/117800212967830061444/posts
http://katiessf.tumblr.com/
http://twitter.com/katiescafesf
mailto:email@address.com
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Figure 29. Verify that the Header and Footer guides are    showing. 

 
 

 
If you prefer, you can also right-click on the left side of the workspace, outside the browser window area and choose the option to Show Header    

and Footer in the menu that   appears. 

Rulers must also be showing to reposition the header and footer guides, so you to set the guides to a specific pixel position. 

Five blue horizontal guides span the width of the page. Starting from the top, these five guides are used to define the top of the page, the bottom          

of the header, the top of the footer, the bottom of the web page and the bottom of the browser window. As you drag the guides to define these        

areas, a tooltip describes each guide and displays its current location. You can to increase the magnification of the page, to zoom in to position the 

guides precisely. 

Note:  The bottom of the browser window guide sets the lowest part of the display shown to visitors. Depending on the design, you can set a fill     

color or background image to fill the browser and set the guide for the bottom of the page above the bottom of the browser guide, if you want the 

browser fill content to show below each page's   content. 

 
 

In this sample project, the browser's fill does not display below the page content. 

2. Drag both the Bottom of the Page guide and the Bottom of the Browser guide to the same location at the bottom of the page, immediately 

below the footer rectangle, as shown in Figure   30. 

Figure 30. When the Bottom of the Page and Bottom of the Browser guides exist in the same location, the browser fill content does not display 

below the bottom of the  page. 

 
 

 
The three upper guides define regions for content displayed in the header, footer, and the unique page content; the center area expands to fit the 



19 

 

 

height of elements added to each  page. 
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3. Drag the Footer guide until it is slightly above the top of the footer rectangle, at around 620px. 

4. Leave the Top of Page guide at the very top (at the Y: 0 px location). Drag the Header guide up to 0px too. 

After making  these changes, the footer section is   complete. 

 

  

Setting page elements as footer items 

 

Be sure to set the elements in the footer region as footer items. This ensures that the footer will always display below the unique page content on  

each page.  Follow these steps: 

1. Use the Selection tool to select all of the content on the Footer page. You can click and drag over the items in the footer, or choose Edit > 

Select All. 

2. Right-click the items and ensure the Footer Item option is checked in the menu that appears. Alternatively, confirm that the Footer checkbox       

in the Control panel is enabled (see Figure   31). 

Figure 31. Verify that the selected footer elements are set as footer items. 

 
 

 
  

Adding an anchor to the top of the page 

 

The Footer master page content displays on all other pages in the site. It’s a good place to add the anchor that will allow visitors to jump back to     

the top of longer  pages. 

1. Click the Anchor button in the Control panel to load an anchor in the Place Gun. 

2. Name the anchor top and position it on the very top of the page (see Figure 32). 
 

Figure 32. Create an anchor named top and move it to the top of the page area. 

 
 

 
Proceed to chapter 3 of Building your first website, where you'll learn about hierarchical master pages and how to apply master pages to individual 

pages. You’ll also see how to create reusable site assets and store them in the Library panel. 
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Chapter 3 – Master page – Styling text -  Styling lines 
 

 

Working with hierarchal master  pages 

Creating the header for the Interior master page 

Creating the header for the Landing master page 

Applying master pages to pages in the design 

Filling a rectangle with a background image 

Formatting  and styling  text content 

Designing a decorative page separator with grouped elements 

Creating a reusable library  item 

Aligning page elements using the page grid guides 

Styling different lines of text inside the same text frame 

Populating  the remainder of  the Home page 

 
 

In Chapter 2 of Building your first website with Adobe Muse, you created new master pages and added site navigation using a Menu widget. You 

learned how to drill down into the sub-elements of widgets, to select them and edit the appearance of states and labels using the States panel.       

You also explored how to add text content and style it using paragraph styles, and took a look at using a Muse Library file to add the Font     

Awesome library with quickly loading page icons. In this section, you’ll see how to create your own library items and reuse them on pages. 

 
  To the top  

Working with hierarchal master pages 

 

Click the Plan link, or click the tab labeled katiesCafe to return to the Plan mode. 

Notice that all of the page thumbnails in the site now display the design elements that you added to the linked Footer master page (see Figure 33). 
 

Figure 33. The Footer master page design is displayed on all of the linked page thumbnails in Plan mode. 

 
 

 
As you design a site, changes you make to the master page automatically update linked pages. Master pages make it easy to update or maintain a   

site. Update one master page to change the site's    appearance. 

You can apply master pages to other master pages. One master page can contain the shared elements that are displayed in a different master  

page (such as the footer described in the previous sections), and then you can create additional master pages that inherit all elements in that 

master page, plus any elements that are unique to a section of the site. 

You can also move copied elements between master pages by choosing Edit > Paste in Place. 

As you hover over a page or master page name, a tooltip displays the hierarchy of the applied masters for that page or master page. 
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Follow these steps to create a new master page that inherits the contents of the Footer master page: 

1. In Plan mode, hover over the Footer page thumbnail and click the plus (+) sign on the right side to create a new master page. 

2. A new master page appears to the right of Footer, named B-Master. Rename the master page: Landing. 

3. Right-click the Footer Copy master page thumbnail and choose Masters > Footer from the context menu. Notice this causes the label 

[Footer] to display below the thumbnail, indicating that the Landing master page is inheriting the content of the Footer master page (see 

Figure 34). 

Figure 34. Set the Landing master page to inherit the content of the Footer master page. 

 
 

 
It's an important distinction that the Landing master page does not actually contain the Footer master page elements — you did not simply         

duplicate the Footer (A-Master) page. Instead, you applied the Footer master page to the Landing master page, which means any new content you    

add to the Footer master page will automatically also appear on the Landing master page. If you need to edit the footer content, double-click the     

Footer master page thumbnail to open it   directly. 

4. Hover over the Landing master page thumbnail and click the plus (+) sign on the right side to create a third master page. Rename it Interior. 

5. Click and drag the Footer master page thumbnail to the new Interior master page thumbnail. Notice that as you drag and drop the Footer 

master page thumbnail onto the Interior page thumbnail, the blue text below the Interior page thumbnail updates from [No Master] to   

[Footer]. 

After you add the design elements to the Landing and Interior master pages, you’ll apply the master pages to the pages in the site map. In this 

design, the Home page uses the Landing master page, and all other pages of the site have the Interior master page applied. 

If you hover over the Landing or Interior master page thumbnails, a tooltip appears that says: Master page applied: Footer. 

In this site example, the master page hierarchy is only one level deep. However, you can create a chain of master pages, where a master page    

that inherits everything one master page can be applied to a third master page, to construct the levels of inheritance several levels deep. 

Compartmentalizing design elements is similar to creating symbols. It’s a best practice to make separate master pages for different sections of a   

site. 

 

Creating the header for the Interior master page 

 

The Interior master page will define the appearance of most of the site’s pages. 

1. Double-click the Interior master page thumbnail to open    it in Design mode. 

2. Draw a rectangle about 90 pixels tall that spans the entire top of the browser window. Drag the side handles until it is set to display at 100% 

width. Align the top of rectangle with the top of the    page. 

3. Set the fill color of the rectangle to Brown and set the stroke width to 0. 

4. Return to Plan mode and double-click the Footer master page thumbnail to open it in Design mode. Select the entire Menu widget and copy        

it. 

5. Return to the Interior master page and paste the menu widget. Use the Selection tool to drag it up to the right side of the brown header. 

6. Click the HOME button twice to select the menu item. Apply the following settings using the Text panel or the Text menu in the Control 

panel: 

 
Web font: Open Sans Condensed Bold 

Font size: 20 

Color: Light Brown 

Alignment: Left 

Tracking: 0 

Leading: 24px 
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Space after: 24 

Paragraph-Level  Tag:  Subhead (h2) 

 
Notice that all of the menu items update to use the same formatting. 

 
7. In the Paragraph Styles panel, create a new paragraph style and name it: subhead. 

8. In the States panel, select the Rollover state. Set the text color to Brown for the Rollover, Mouse Down, and Active states (see Figure 35). 
 

Figure 35. Set the rest of the menu item states to use the Brown text color. 

 
 

 
There's just one remaining item to add to the header for the interior master page. 

1. Choose File > Place (or use Command+D on Mac or Control+D on Windows) to open the Import dialog box. Browse to select the file in the 

sample  files folder  named logo-interior.png  and then click OK. 

2. Click once on the left side of the header to place the logo image on the page. Use the Selection tool to reposition the graphic so that it is 

centered with the Menu widget, in the vertical center of the brown rectangle. 

At this point, the top-level site navigation in the Interior master page is complete. 

3. Click Preview to see the master page rendered in Muse (see Figure 36). 
 

Figure 36. The  completed header is  displayed  on the Interior master  page. 

 
 

 
4. Click Design to continue editing the master   pages. 

 

 
  

Creating the header for the Landing master page 

 

Next, you’ll populate the Landing master page, which defines the header for the Home page. This header is very similar, but does not include a 

brown rectangle. 

1. In Design mode, copy the Menu widget on the Interior    page. 

2. Open the Landing master page in Design mode and choose Edit > Paste in Place. 

3. While the menu is still selected, press and hold the Shift key while pressing the down arrow four times, to move the menu approximately 40  

pixels down from the top of the  page. 

4. Choose File > Place and then browse to select the file in the sample files folder named logo-landing.png and then click OK. 

5. Click once on the left side of the header to place the transparent logo image on the page. Use the Selection tool and smart guides to 

position the graphic so that it is centered with the Menu    widget. 
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At this point, the top-level site navigation in the Interior master page is also complete. 

 

 
  

Applying master pages to pages in the design 

 

If desired, you can right-click on each page thumbnail and choose the name of the master page you want to apply to each page. But it’s usually  

faster to just drag and drop the master   pages: 

1. Click and drag the Landing master page thumbnail to the HOME page thumbnail to apply it. The blue text below the HOME page thumbnail 

updates from [No Master] to  [Landing]. 

Click and drag the Interior master page thumbnail to all of the remaining pages in the site map. Notice that the thumbnail designs update as you 

apply each master  page. 

 
  

Filling a rectangle with a background image 

 

1. In Plan mode, double-click the HOME page thumbnail to open it in Design mode. 

Notice that you cannot select the header and footer elements on the page. They are in the master pages (Landing and Footer) and can only be 

edited on those  pages. 

2. Draw a rectangle that spans the top of the page, set to display at 100% width. 

3. Use the Fill menu to click the folder icon next to the Image section. In the Import dialog box that appears, browse to select the file in the 

sample  files folder  named img-salad-darker.png and then  click  Open  (see Figure 37). 

Figure 37. Set  the background fill image for the   rectangle. 

 
 

 
4. Set the Fitting menu to Scale to Fill and click the upper right position in the Position section to align the image by its top right corner on the  

page. 

5. Click anywhere else on the page to close the Fill   menu. 

6. Use the Selection tool to drag the handles and resize the rectangle as needed. Use smart guides to position the graphic so that it is centered    

and align the top edge of the image with the top of the browser window. 

Formatting and styling text content 

 

Next, you’ll add some text frames and set up paragraph styles to control the text’s appearance. 

1. Use the Text tool to draw a text frame that is centered below the rectangle you created in the header area. 

2. Type the words: WELCOME TO KATIE’S CAFÉ. Use the Text panel or the Text menu in the Control panel to set the following attributes:  

Web font: Open Sans Condensed  Bold 
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Font  Size:  50 

Font  Color: Brown 

Alignment: Centered 

Tracking: 1 

Leading: 48px 

Paragraph-Level  Tag:  Headline (h1) 

3. Create a new paragraph style and name it:   heading 

4. Create a second text frame below the heading and type: A small family-owned chain of cafés in San Francisco. 

5. Set  the following attributes: 

Web font: Gentium Book Basic Bold Italic 

Font Size: 16 

Font Color: Light Brown 

Alignment:  Left 

Tracking: 1 

Leading: 24px 

Paragraph-Level  Tag:  Subhead (h3) 

6. Create a new paragraph style and name it: Subhead   serif 

 
Usually, the subhead text will be left aligned. But for this particular instance on the home page, you’ll align it to the center. 

 
7. While the text is still selected,    set the alignment to centered. 

 
Notice that the Paragraph Styles panel now displays a plus (+) sign next to the paragraph style’s name. This indicates that the currently 

selected text has the paragraph style applied, but at least one attribute of the style has been changed. 

 
8. Hover over the paragraph style’s name and a tooltip displays the text settings. Any attributes that are different from the original style’s 

attributes are listed below the line. In this case, the item below the line says: align: center (see Figure 38). 
 

Figure 38. A plus sign indicates that the text uses different formatting and the tooltip specifies what is different between the selected text and the 

paragraph style. 

 
 
 

Designing a decorative page separator with grouped  elements 

 

Below the two text frames, you’ll add a decorative page    separator. 

1. Show the guides by choosing View > Show    Guides. 

2. Use the Rectangle tool to draw a rectangle that is 445 pixels wide and 20 pixels tall. Position it so it spans the left half of the page (aligned    

with the left side of the 9 column page grid) that extends into the center of the page. 

3. Set the rectangle’s fill color to none. Set the stroke color to Light Brown. In the Stroke Options, unlink the fields. Set the top stroke width to 2 
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and all others to 0, the same way you created a line for the footer design. 

4. Press Option/Alt and use the Selection tool to drag a copy of the rectangle horizontally, so that it is aligned with the first rectangle and its    

end aligns with the right side of the page   grid. 

5. Use the Text tool to create a small text field between the two rectangles, in the center of the page. 

6. Outside of Muse, open the Character Viewer to insert a special character. Search for the term: White Four Pointed Star and then insert the   

item twice, to create two  stars. 

7. In the Text panel, apply the following   settings: 

 
Web font: Gentium Book Basic 

Font size: 24 

Color: Light Brown 

Align: Center 

Tracking: 3 

Leading: 24px 

There’s no need    to set a paragraph-level tag for this decorative text frame. 

8. Select the two rectangles and the text frame and choose Object > Group. 

 

 
  

Creating a reusable library item 

 

1. Open the Library panel by choosing Window >   Library. 

2. Click the folder icon on the bottom right side of the Library panel to create a new folder. 

3. Click in the field of the new folder and name    it: Page Designs. 

4. Select the group you created in the previous section. Click the Add Selected Item button (page turn icon) to add the group of elements to the 

folder. Rename the library item: Page Separator (see Figure    39). 

Figure 39. Create and name a new item inside the folder of the Library panel. 

 
 

 
Notice that a preview of the group is displayed in the Library to help you identify elements. 

In future sections of this article, you’ll click the Page Designs folder in the Library panel to expand it and then drag a copy of the Page Separator to      

the page. 

 

Aligning page elements using the page grid guides 

 

Next you’ll draw three rectangles, use the column grids on the page to align them, and fill them with background images. 

1. Use the Rectangle tool to draw a rectangle that is approximately 304 x 304 pixels. 

2. Use the Selection tool to align the left side of the rectangle with the left side of the page. 
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3. Press and hold Option/Alt and drag a copy of the rectangle to the center of the page with a small space between it. Option/Alt-drag the 

center rectangle and position the second copy so that it aligns with the right side of the page. 

4. Select the first rectangle on the left again. Use the Fill menu to set the background image to use the file named img-coffee.jpg. Set the 

Fitting menu to Scale to Fill, and then click the center point in the Position section. Click away to close the Fill menu. 

5. Repeat step 4 to set the background fill of the middle rectangle and right rectangles using the same settings. Except set the fill of the middle 

rectangle to use img-baking.jpg and set the right rectangle to use the img-dinner.jpg image (see Figure 40). 

Figure 40. Align the three filled rectangles using the page    guides. 

 
 

 
  

Styling different lines of text inside the same text  frame 

 

Below  the three filled rectangles, you’ll create three styled text   frames. 

1. Draw out a text frame that spans the same first three columns below the rectangle aligned on the left side of the page. Type the following    

text, hitting the Return/Enter key to create a line break between the first line of text and the rest of it: 

 
The finest coffee & tea 

 
We serve only premium roast coffees from around the world and offer fresh coffee for each customer. We also offer a selection of loose leaf  

teas, everything from exotic flavors to the   classics. 

2. Use the Selection tool to select just the first sentence. Right-click on the text, and choose Change Case > UPPERCASE to make the header       

of the text frame stand  out. 

3. Open the Paragraph Styles panel and    apply the subhead style. 

4. Select the remaining text in the text frame. Use the Text panel to apply these settings: 

 
Font: Gentium Book Basic 

Font size: 16 

Color: Brown 

Alignment: Left 

Tracking: 0 

Leading: 24px 

Space After: 24 

Paragraph-Level  Tag:  Default (p) 

5. You’ll reuse    this style frequently, so create a new paragraph style named: body. 

 
6. Create a second text frame that spans the three center page grid columns, below the center rectangle. Type the following: 

 
Delicious home baking 

 
Based on Katie’s original award-winning recipes, we serve a full menu of baked goods. These items are made fresh each morning to ensure    

you are getting the best quality  possible. 

7. Change the case of the header to uppercase. Apply the subhead and body paragraph styles. 

8. Create a third text frame below the right rectangle. Style the text like the other two text frames after typing: 
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Fresh & healthy meals 

 
With an extensive breakfast, lunch, and dinner menu, we do more than your typical café. All our meals are made to order and contain only     

the freshest ingredients. 

9. Use the Text tool to create a new text field below the other three text fields that spans the first 4 columns on the left side of the page. Type: 

 
Introducing our seasonal cupcake 

 
For a limited time, you can get one of our Maple Walnut Cupcakes. Based on the same ingredients that make all our cupcakes taste so 

good, plus the rich and decadent flavors of maple and walnut, you won’t want to pass these up. 

 
Katie Ricks 

 
10. Set    the header’s case to uppercase and apply the paragraph style: subhead. 

11. Select the center two sentences and apply the body paragraph    style. 

12. Select the name Katie Ricks. Use the Text panel to apply the following settings: 

 
Web font: La Belle Aurore 

Font size: 42 

Color: Brown 

Alignment: Right 

Tracking: 0 

Leading: 24px 

Space After: 6 

 
This font formatting creates the illusion of a   signature. 

13. Use the Selection tool to select the entire text frame. In the Fill menu, set the fill color to white and set the opacity slider to 77. 

 

 
 

Populating the remainder of the Home page 

Follow these steps to add the content to the bottom of the Home page. 

1. Draw a rectangle that spans the page below the three text frames, set to display at 100% width. 

2. Use the Fill menu to fill the rectangle with a background image named img-cupcakes.jpg. Set the Fitting menu to Scale to Fill and click the 

upper left position in the Position section to align the image by its top left corner on the page. 

3. Click anywhere else on the page to close the Fill   menu. 

4. Use the Selection tool to drag the handles and resize the rectangle as needed. It should be centered, display at 100%, and align the top  

edge of the rectangle at approximately 1214 pixels from the top of the page. 

5. Right-click on the rectangle and choose Arrange > Send to Back. The text frame with the signature that you created earlier should now 

appear on top, and its semi-transparent background allows the cupcake image to show through. 

Next you’ll repurpose  some of the elements you created previously, by copying    them. 

1. Scroll  up and select the header text frame: WELCOME TO KATIE’S   CAFÉ. 

2. Press Option/Alt and drag it down below the rectangle filled with cupcakes. Use the text tool to type over the header and replace the text  

with: ABOUT  KATIE’S CAFÉ. 

3. Open the Library panel. Expand the Page Designs folder and drag a copy of the Page Separator to the page below the text frame. Center   

both elements on the  page. 

4. Draw a rectangle that is approximately 450 pixels wide x 300 pixels tall. Fill the rectangle using the background image named img- 

cookie.jpg. Set the background to Scale to Fill and click the center Position point. 

5. Align the rectangle with the left side of the   page. 

6. Draw a text frame to the right of the cookie rectangle, approximately 450 pixels wide. Type or paste the following text: 

OUR STORY 

Katie's Café is a small family-owned chain of cafés in San Francisco, California, USA. The original Katie's location in Noe Valley opened it's doors       

in the summer 2006 after founder Katie Ricks decided to spread her love of delicious baked goods and quality coffee to the neighborhood she    

resided in. 

Katie's in Noe expanded its menu to include full meals in addition to baked goods in 2007. Soon afterward in spring 2008 Katie's opened a new 

location in Laurel Heights just north of the University of San Francisco. A third location in Cole Valley opened in winter 2011. 

Every item served at Katie's Café is created from Katie's own recipes, painstakingly crafted through years of baking for friends and family. 
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1. Apply the subhead style to the header and the body style to the rest of the text frame. 

2. Align the right edge of the text frame with the right side of the page guides. 

And finally, you’ll add one more set of filled rectangle and text frames along the bottom. 

 

 
1.  Scroll down and draw a text frame below the cookie rectangle, approximately 450 pixels wide. Type or paste the following text: 

AWARDS 

Katie's Café has won several awards in the annual San Francisco Times Best of SF competition, most notably Café of the Year in 2010. 

Katie's was also recently featured in an episode of No Fear: The Culinary Travels of Andrew Bourdin; Andrew pronounced her Abomination Unto     

the Lord Cake "a life-changing experience that has ruined me for all other cakes." 

1. Apply the subhead style to the header and the body style to the rest of the text frame. 

2. Align the left edge of the text frame with the left side of the page guides. 

Next, you’ll create a filled  rectangle. 

1. Draw a rectangle that is approximately 450 pixels   wide. 

2. Set the rectangle’s fill color and stroke to none. Set the background fill to use the img-breakfast.jpg image, with Fitting set to Scale to Fill     

and the position set to top  left. 

3. Align the rectangle along the right side of the page guides, below the Our Story text frame. 

4. Open the Library panel and expand the FontAwesome Folder. Drag the Directional icons item to the lower right part of the page, just above     

the footer guide and aligned with the right side of the    page. 

5. Click the blue arrow button to open the Options menu. Select the Circle Arrow Up option from the menu. Set the text color to Brown (see 

Figure 41). 

Figure 41. Configure the Font Awesome icon and style it to match the site design. 

 
 

 
6. While the Arrow Up icon is still selected, use the Hyperlinks menu to select the anchor link named top (see Figure 42). 
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Figure 42. Set the link to point to the anchor named top that you created in the master page. 

 
 

 
7. Choose File > Preview Page in Browser. Scroll down the page to see the page contents. Click the Arrow Up icon and see how the page 

jumps back to the top of the  page. 

8. Click Design to continue editing the Home page. If desired, choose View > Hide Guides to hide the guides on the page. 

In the next section of this tutorial, Chapter 4, you'll see how to apply scroll effects to control motion and create an interactive effect on the home     

page. You’ll also see how to create a manual Menu widget to create sub-navigation for the Menu page. And then you’ll apply anchors to the page    

and link the menu items to the anchors, before adding a second “hidden” menu that appears as the visitor scrolls down the page. 
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Chapter 4 – Applying Scroll effects – Manual widgets  
 

 

Applying scroll effects to rectangles filled with background images 

Creating the Menu  page 

Configuring  a manual  Menu widget 

Working with anchor tag regions and active states 

Adding  anchor links to  menu items 

Adding the five sections to the Menu   page 

Placing text content to populate the menu content for each section 

Adding scroll effects to the section headers on the Menu page 

Adding a “pinned” menu to the header using scroll    effects 

 
 

In Chapter 3 of Building your first website with Muse, you added and edited master page to add site navigation using a Horizontal Menu widget.   

You learned how to style the appearance menu items and labels using the States panel. You also learned how to work with Library items and   

create reusable elements that you can drag and drop on    pages. 

 
  

Applying scroll effects to rectangles filled with background  images 

 

There are many types of scroll effects you can apply in Muse, including motion, opacity, slideshow, and Edge Animate scroll effects. You can 

apply scroll effects using the Scroll Effects panel and also control motion by using the Scroll tab of the Fill menu. 

1. Scroll up and select the large rectangle aligned with the top of the page. 

2. Select Window > Scroll Effects. On the Scroll Effects panel, enter the following settings (see Figure 43). 

 
Enable the Motion checkbox 

Leave the two fields in the Initial Motion section set to 0 

Set the key position (the center field) to  0px 

Enable the Up direction in the Final Motion section and set it to 0.5 

Leave the horizontal direction set to  0 

Figure 43. Apply the scroll effect motion settings to the rectangle in the header of the page. 

 
 

 
These settings indicate that once the page has scrolled past the key position (0 pixels, the very top of the page), then the rectangle should scroll       

up at a rate of .5 times the rate that the rest of the page scrolls. 

3. Choose File > Preview Page in Browser. Scroll the page down and notice that the top rectangle in the header moves half as fast as the rest        

of the page elements. 

4. Return to Muse and scroll down to select the large rectangle filled with the image of cupcakes. 
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5. Open the Scroll Effects panel (Window > Scroll Effects), and enter the following (see Figure 44). 

Enable the Motion checkbox 

Enable the Up direction in the Initial Motion section and set it to 0.5 

Leave the horizontal direction set to  0 

Set the key position (the center field) to  1114px 

Enable the Up direction in the Final Motion section and set it to 0.5 

Leave the horizontal direction set to  0 

Figure 44. Apply scroll effects to control the motion of the rectangle as the page scrolls. 

 
 

 
6. Choose File > Preview Page in Browser again. Scroll the page down and notice that both 100% width rectangles move up half as fast as the    

rest of the page  elements. 

7. Return to Muse. Click the X to close the Home page tab in Design mode. 

 

 

Creating the Menu page 

 

The menu page features a series of items available for breakfast, lunch, dinner, and dessert, as well as drinks. To navigate the page, visitors use        

a menu bar with anchor links that jump to each    section. 

1. Open the Menu page in Design mode. Show the guides to help you layout the page. 

2. Use the Text tool to draw a text frame that is centered below the header area. 

3. Type  the words:  FRESH LOCAL INGREDIENTS &  INNOVATIVE RECIPES 

4. Apply  the paragraph style: heading. 

5. Use the Selection tool to resize the text frame, so that it spans the entire page. In the example site, the text wraps after the ampersand to a 

second line. 

6. Drag a copy of the Page Separator from the Library panel and center it below the text. 

 

 
  

Configuring a manual Menu widget 

 

When designing the Footer master page, you added a Menu widget that linked to all the pages in the site. Next you’ll add a manual Menu widget    

that links to different sections of the same   page. 

1. In the Widgets Library, expand the Menus section and drag a Horizontal Menu widget to the page. 

2. Use the Selection tool to resize the width of the entire menu, so that it spans the 5 center columns of the grid guides. 

3. Click the blue arrow button to open the Options panel. Apply the following settings (see Figure 45): 

Menu Type: Manual 

Direction: Horizontal 

Edit Together: Enabled 

Item Size: Uniform Spacing 
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Show Left Icon: Disabled 

Show Label: Enabled 

Show Right Icon: Submenus Only 

Parts Positioning: Horizontally, Centered 
 

Figure 45. Set the Menu Type to Manual in the Options panel. 

 
 

 
4. Click away to close the Options panel and notice the menu updates to a single menu item with the label: [Name] 

5. Click twice on the menu item, once to select the entire Menu widget, and again to select the menu item. Use the Text tool to select the 

placeholder label and type:  BREAKFAST. 

6. Switch to the Selection tool and hover over the menu item. Click the plus (+) sign that appears to the right of the BREAKFAST menu item,        

to create a new menu item. Use the Text tool to rename the new button: LUNCH. 

7. Repeat step 6 to add a total of three more menu items and rename them: DINNER, DESSERT, and DRINKS. 

8. While one of the menu items is selected, open the States panel. Select the Normal state and set the menu item’s fill color to none. Then,    

click each of the remaining Roll Over, Mouse Down, and Active states and set their fill color to none. 

9. Select the Normal state and set the stroke color to Light Brown. In the Stroke options, unlink the four fields and set them all to 0, except set      

the right side stroke to 2. This creates separators between each menu item. 

10. In the Options panel, deselect the option: Edit Together. Select the BEVERAGE menu item and the Normal state, and then set the stroke   

color to none. Repeat this step for the Active state. Then, re-enable the Edit together option. 

11. Select the Normal state again. Apply the subhead paragraph style. Use the Text panel to make the following additional changes to the text 

formatting: 

Font: Open Sans 

Size: 16 

Alignment: Centered 

Space After: 0 

The subhead style now displays a plus (+) sign next to it, indicating it has changed. If you’d like you can create a new paragraph style, but it       

is fine to just leave this  as-is. 

12. The Roll Over and Mouse Down states update automatically. Repeat step 9 to apply the same formatting to the Active state. 

13. Use the Selection tool to align the menu so that it is centered vertically and approximately 52 pixels below the page separator. 

At the moment, the menu does not have any links. Manual Menu widgets must be set up to use the links you want, because they do not inherit the   

page links from Plan  mode. 

 
  

Working with anchor tag regions and active states 

 

The Menu page will contain a total of five different sections with food and beverage items, separated by large 100% width rectangles. As a result,       

the entire contents of the page cannot be displayed without scrolling down. This is an important aspect of working with both anchor tags and scroll 
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effects. Both site features will appear not to work if the page is not long enough for the visitor to scroll down it. 

Imagine that when you add anchor tags, it is like affixing a marker somewhere on a page. When visitors click a link to that anchor, the link will   

scroll down to where the marker is   located. 

You'll begin by creating five anchors named: breakfast, lunch, dinner, dessert, and drinks that correspond to each of the five page regions. Follow 

these steps: 

1. Click the Anchor button in the Control panel to load the Anchor tool (see Figure 46). 
 

Figure 46. Load the Place Gun for the first anchor by clicking the Anchor button. 

 
 

 
2. Click once near the top left part of the page, just below the page separator, to place the anchor. 

3. In the Rename an Anchor dialog box that appears, enter the anchor's name: breakfast. Use the Selection tool to move it to about 303 pixels  

from the top of the page (see Figure   47). 

Figure 47. Name the anchor for the breakfast menu near the top of the page. 

 
 

 
4. Repeat these steps. This time, click the Anchor button four times, and then click on the page to place named anchors at the following 

positions down the  page: 

lunch: 1255px 

dinner: 1731px 

dessert: 2798px 

drinks: 3200px 

If desired, you can use the Transform panel to select each anchor and set its Y value. 

 
Note:  The amount of spacing between the first anchor and the first instance of the linked content (the manual Menu widget) sets the "active area"    

that causes the active state to change in each region. For example, if the first anchor is positioned 100 pixels above the menu, the active state of       

the menu items for each region update 100 pixels before the menu appears as the visitor scrolls down the page. 

 
 

Next, you’ll link the menu items to the anchor tags to create navigation so visitors can jump down the page to read each menu. 

 

 
  

Adding anchor links to menu items 
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1. Click the BREAKFAST menu item twice, to select it. The Selection Indicator displays the words: Menu item. 

2. Use the Hyperlinks menu to select the breakfast anchor tag in the Menu page (see Figure 48). 
 

Figure 48. Set the link for the BREAKFAST button to the breakfast anchor tag. 

 
 

 
3. Repeat step 2 to add the anchors to the remaining four menu items. 

4. Choose File > Preview Page in Browser to test the menu and see how it jumps down to each section of the page. Scroll back up to click   

each of the buttons. 

It is a bit tiring to keep manually scrolling back up, so later you’ll add Back to Top buttons and a hidden menu with scroll effects that will allow a 

second Menu widget to remain in the header   area. 

5. Return to Muse to continue editing the Menu   page. 

 

 

Adding the five sections to the Menu page 

 

This page uses a design similar to the Home page, with rectangles set to 100% width that have scroll effects and styled text frames. 

1. Drag a rectangle out that spans the width of the entire browser window, approximately 52 pixels below the Menu widget. 

2. Set the fill and stroke color to none. Set the background image of the rectangle to use the file named img-breakfast.jpg. Set the image to  

Scale to Fill and set its position to the center left   point. 

3. Resize the rectangle by dragging its handles until the edges are aligned on both sides, indicating that it will display at 100% width. Set the 

height of the rectangle to 267  pixels. 

4. Create  a text frame and type:  BREAKFAST. 

5. In the Library panel, expand the FontAwesome icon folder and drag a Directional icon to the page. Use the Options panel to select the Circle 

Arrow Up icon. Set the text color to Light   Brown. 

6. Cut the Circle Arrow Up icon, then use the Text tool to click immediately in front of the B in the text frame: BREAKFAST. Paste the Circle 

Arrow Up icon inside the BREAKFAST text   frame. 

7. Set the link for the Circle Arrow Up icon to the top anchor link on the Menu page. 

8. Select the BREAKFAST text and apply the heading style. Then, edit the font attributes by setting the font color to Off White and the 

alignment to Left. 

9. Position the BREAKFAST text frame 600 pixels from the top (Y) and 4 pixels from the left side of the page (X). You can use the transform 

panel or the tooltips to help you position   it. 

10. Select the BREAKFAST text frame, press and hold the Shift key, and then select the rectangle filled with the breakfast image. Release the   

Shift key and then press and hold the Option/Alt key to drag a duplicate copy of the two elements down the page, keeping the new set     

aligned to the center. This copy will become the lunch    section. 

11. Position the Lunch set to 1205 pixels from the top of the page. Use the Text tool to select the word BREAKFAST and type LUNCH. In the      

Fill menu, set the background image to use the img-lunch.jpg file. Keep the Scale to Fill setting, and set the position to center right. 
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12. Repeat steps 10 and 11 to duplicate the Lunch section. Position the dinner set at 1977 pixels from the top of the page. Rename the text 

frame DINNER. Set the background image to use img-dinner.jpg. Use the same Fitting and Position settings. 

13. Repeat steps 10 and 11 to create the dessert section. Set the dessert rectangle fill to use the img-dessert.jpg background image, with its 

position set to the center left. Update the text frame to say DESSERT, and position the top edge of the dessert rectangle to a Y value of  

2748. 

14. Duplicate the dessert set to make the drinks section. Type over the text frame to rename it DRINKS. Set the background image of the 

rectangle to img-drinks.jpg, using the top left position. Set the top edge of the drinks rectangle to a Y value of 3446. 

The section headings are now complete. If desired, click Preview to test how you can click the back to top arrow buttons to jump back up after 

visiting each section. 

 

 

Placing text content to populate the menu content for each section 

 

Next you’ll add two text frames in the spaces between the sections to display the corresponding food selections for each category. 

1. Choose File > Place and browse to select the text file named breakfast1.txt located in the menu subfolder of the Assets folder. Click Open to  

close the Import dialog  box. 

2. Click once on the page below the Breakfast header to place the text file with the following content: 

The Spike $9 

Breakfast burrito with egg, black beans, guacamole, onion, cilantro, chipotle tomato salsa, and your 

choice of potato, chicken, or beef 

The Dazzler $7 

Hash browns with scrambled eggs and locally sourced bacon 

The Nessie $8 

Two hearty buttermilk pancakes with your choice  of chocolate chips or blueberries 

3. Select each of the item names (with prices) and apply the subhead serif paragraph style. Then, select the item descriptions below each one   

and apply the body paragraph  style. 

4. Align the left side of the text frame with the left side of the page. Resize the text frame to center vertically between the Breakfast and Lunch 

headers. Expand the width of the text frame to span the first four columns. 

5. Repeat steps 1 – 4 to place the text file named breakfast2.txt. Style the text and position the text frame to align on the right side of the page, 

spanning the last four  columns. 

6. Continue this process to populate each of the menu sections, placing lunch1.txt and lunch2.txt content and styling the two text frames, and  

then repeating these steps to add two text frames with the food options to the dinner, dessert, and drinks sections. 

7. Save the site and preview the page. It is looking complete, but you’ll add the finishing touches by applying some scroll effects in the next 

section. 

 
  

Adding scroll effects to the section headers on the Menu page 

 

This part is very similar to the scroll effects you added on the Home page. Remember that when you added the background images for the 100%   

width rectangles, you varied the alignment by selecting different positioning in the Fill menu. Also note that each rectangle is only 267 pixels tall,       

but the background source images are over 1,300 pixels in height and set to Scale to Fill. These settings will affect how the scroll effects display    

when viewed in a  browser. 

 

1. Select the rectangle in the Breakfast section. Open the Scroll Effects panel (Window > Scroll Effects), select the Motion checkbox and 

enter the following attributes to control the movement of the fill content      (see Figure 49). 

 
In the Initial Motion section, set the Up direction to scroll at a rate of 0.5x 

Leave the horizontal direction set to  0x. 

Set the key position to 440px (You can also drag the T-handle on the page to set this)  

In the Final Motion section, set the Up direction to scroll at a rate of  0.5x 

Leave the horizontal direction set to  0x. 
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Figure 49. Enable the Motion  checkbox and apply the scroll effect    settings. 

 
 

 
2. Select the Lunch rectangle. In the Scroll Effects panel, set the key position to 1205px. Set the Up directions for both the Initial Motion and  

Final Motion sections to 0.5x. Leave    the horizontal directions set to 0x. 

3. Repeat step 2 to apply scroll effects to the Dinner rectangle. Use the same settings, but set its key position to 1977px. 

4. Continue repeating this operation two more times. Set the Dessert rectangle to use a key position of 2748px. Set the Drinks rectangle to use        

a key position of 3446. 

5. Choose File > Preview Page in Browser to see the scroll effect in action. Click the Dessert menu item and watch the rectangle headers 

move as the page jumps down to the Dessert section. Click the Up arrow icon to jump back up to the top. 

When you are finished testing, close the browser and return to Adobe Muse. 

 
 

Adding a “pinned” menu to the header using scroll effects 

 

The Menu page is almost complete, but it is still a bit difficult to navigate. It would be easier if there was a Menu widget that appeared above each 

section on the page, so you could easily jump to each section without going all the way back to the top first. This is a technique you can use to        

make the Menu widget appear to scroll up and then get “stuck” at the top of the page. 

1. Select the Menu widget at the top of the   page. 

2. Press and hold the Option/Alt key while dragging a duplicate copy of it up towards the header. As you drag, make sure that you keep the 

duplicate vertically aligned with the original and with the center of the page, using the smart guides that appear. 

3. Position the duplicate header immediately below the brown header rectangle, with a Y position of 92 pixels. 

4. Open the Scroll Effects panel. Click the Opacity tab (second from the left) to see the opacity settings for scroll effects. 

5. Enable the Opacity checkbox and apply the following settings (see Figure 50). 

Fade Position 1:  5px at 0% 

Key Position: 252px at 0% 

Fade Position 2: 252px at 100% 
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Figure 50. Set  the settings to control  the transparency of the Menu   widget. 

 
Note: You can also set the Fade Position 1, Key Position, and Fade Position 2 values by dragging the corresponding parts of the T-Handle that 

appears above  the menu  once you enable  scroll effects. 

 
 

The settings above mean that the menu will remain completely transparent (0% opaque) until the visitor scrolls the page down to 252 pixels from     

the top. When that happens, it also happens that the first (visible) Menu widget moves exactly into the same location. 

To smooth the transition when the duplicate menu shows and the original menu scrolls up and away, you’ll add a solid rectangle that has the      

same fill color as the background of the page. That way, the rectangle (which is drawn above the duplicate menu) can also use scroll effects so     

that it prevents the moment when the menu appears extra bold (as the menus display on top of each other). 

6. Draw a rectangle directly below the brown header. Use the Transform panel to apply the following values (see Figure 51): 

 
Height: 45 pixels 

Width: 1160 pixels 

X: -100 pixels 

Y: 87 pixels 

Set to display at 100% width 
 

Figure 51. Set  the rectangle that covers up the duplicate  menu  to display 100%   width. 

 
 

 
1. In the Opacity tab of the Scroll Effects panel, enter the following values: 

 
Fade Position 1: 5px at 0% 

Key Position: 252px at 0% 

Fade Position 2: 252px at 100% 

The settings above ensure that the rectangle above the duplicate menu hides it until right when the original menu scrolls above it, creating a 

seamless transition. 

2. Choose File > Preview Page in Browser to scroll the page down. Scroll slowly and watch the first menu scroll up, and the duplicate 

(transparent) menu appear right as the original scrolls out of view. Scroll effects also control the duplicate menu’s motion, which make it 

remain in place as you continue scrolling down the   page. 

In the next chapter of Building your first website with Adobe Muse, you'll see how to resize and crop placed image files and align them on the grid 

columns. You’ll also add a Fullscreen Slideshow widget and configure it to display a gallery of images. And then you’ll learn how to incorporate third-

party site content by embedding HTML into the Blog    page. 
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Chapter 5 – Gallery Pages – Text Frames – Embedded HTML 
 

 

Formatting text at the top of the Gallery page   

Placing multiple resized images using the Place gun 

Cropping  placed images 

Applying links to text frames and defining the default link style 

Adding and configuring a Fullscreen Slideshow widget 

Formatting text at the top of the Blog   page 

Using embedded  HTML to display a blog on a Muse   site 

 

 
In Chapter 4 of Building your first website with Muse, you added scroll effects to create interactive motion effects to the Home page. You also built      

out the Menu page and created a manual menu that linked to different anchors on the page. In Chapter 5, you'll see how to edit placed images by 

resizing them and cropping them within the Muse workpace. You’ll also explore working with embedded HTML to add a Tumblr blog to the Blog      

page. 

 
  

Formatting text at the top of the Gallery page 

 

The Gallery page includes a series of images that are aligned using the page guides. 

1. Open the Gallery page in Design   mode. 

2. If the guides are not already showing, choose View > Show Guides. 

3. Create a text frame and type: GALLERY. Apply    the header paragraph style. 

4. Create a second text frame that is aligned to the left side of the page. Type: 

 
Ever since Katie’s Café first opened its doors in 2006 we have been dedicated to sourcing fresh local 

ingredients and providing the quality finished product to our customers. Founder, Katie   Ricks, 

 

and then apply the body paragraph   style. 

 
5. Create a third text frame that is aligned to the right side of the page. Type: 

 
is passionate about food and customer service. This passion is what inspires every menu item and we are 

proud of the classics, as well as the new items that we  serve. 

 

Again, apply the body paragraph  style. 

 
6. Use the Selection tool to select both the left and right paragraphs and choose Object > Group. 

7. Drag a copy of the Page Separator from the Library   panel. 

8. Use the Selection tool to center the three elements (header text, group of two text columns, and page separator graphic) to align them 

vertically on the page (see Figure   52). 

Figure 52. Position the text frames and page separator to fit below the header content. 
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Placing multiple resized images using the Place  gun 

 

1. Choose File > Place and browse to select the files in the Assets folder  named gallery-1.jpg, gallery-2.jpg, gallery-3.jpg, and gallery-9.jpg.  

Click Open to select them and close the Import dialog    box. 

Notice that the Place gun displays the number 4, indicating that there are 4 images loaded. 

2. Click and drag your cursor on the left side of the page. A tooltip temporarily displays a percentage to let you know the scale of the first     

image you are placing. Release your mouse button when the image has been scaled approximately 16%, so that the image's dimensions    

are 330 pixels wide by 220 pixels  high. 

3. Repeat step 2 to place the other three images at the same    scale. 

Don’t worry about the alignment yet. First, you’ll edit the images from within Muse. 

 

 
  

Cropping placed images 

 

Next, you’ll crop each of the four image files, so that they are all square (220 x 220 pixels). 

1. Use the Crop tool to select the gallery-1.jpg   image. 

2. Click once in the center to make a black circle icon appear. The border around the image turn blue and the open hand cursor appears. Drag     

the image inside the image frame to the left, until the left side of the coaster is cut off and displays in the semi-opaque area. 

3. Click the image again with the crop tool. The center circle icon disappears and the border around the image frame turns orange. Drag the   

right center handle towards the middle to resize the image’s width to 220 pixels (see Figure 53). You can look at the Transform panel to    

check the dimensions. 

Figure 53. Crop the sides of the placed image using the Crop tool. 

 
 

 
4. Repeat steps 1-2 to crop the gallery-2.jpg, gallery-3.jpg, and gallery-9.jpg images so that they are all 220 pixels wide. 

5. Use the Selection tool to align the four images along the width of the page (see Figure 54). 
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Figure 54. Align the four cropped image frames in the columns created by the page guides. 

 
 

 
The rest of the Gallery page is comprised of resized images and text frames. 

1. Place the image named gallery-4.jpg and click-drag it to place it at 38%. Use the Crop tool to crop off the left edge, and then reduce the 

image frame’s width, until its dimensions are 464 x 512 pixels. Use the Selection tool to align the left edge with the left side of the page. 

2. Place the image named gallery-5.jpg to the right of the larger image you just cropped. Click-drag it to approximately 24%. Use the same 

technique as before, sliding the image over inside the image frame to center it. This time, drag the bottom handle up and the right side  

handle towards the center to crop it to 264 x 246 pixels. Align the right edge with the right side of the page guides, and align the bottom    

edge with the bottom of the gallery-4.jpg   image. 

3. Place gallery-6.jpg and click-drag it to 50%. This image will span the entire page. Center the image in the image frame and crop it to 953 x     

516 pixels. Align it vertically on the   page. 

4. Place gallery-7.jpg and click-drag it to 23% on the left side of the page. Crop it to 464 x 342 pixels and align it with the left side of the page. 

5. Place gallery-8.jpg and click-drag it to 23% on the right side of the page. Crop it to 464 x 310 pixels and align it to the right side of the page.     

Use the Selection tool and the smart guides to ensure the images are all lined up with the page guides and with each other (see Figure 55). 
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Figure 55. Arrange the cropped gallery images in a mosaic pattern on the page. 

 
 

 
There’s an empty spot above the image of the cupcakes (gallery-5.jpg). You’ll fill it with a text frame. 

 

 
  

Applying links to text frames and defining the default link  style 

 

You’ll add a button that allows the visitor to view the fullscreen slideshow. 

1. Draw a text frame above the image of the cupcakes. Resize it to 464 x 242 pixels and align it with the right side of the page. Set the fill color        

of the text frame to Light  Brown. 

2. Type:  VIEW GALLERY FULLSCREEN 

3. Apply the heading paragraph style. Then, set the color to Off White and set the alignment to Left. The text will wrap to two lines. 

4. While the text frame is selected, use the Hyperlinks menu to apply a link to the Gallery-fullscreen page (see Figure 56). 
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Figure 56. Set the text frame up as a link to the page that displays the gallery slideshow. 

 
 

 
5. Click the Hyperlinks text to the left of the Hyperlinks menu, to see the available options. In the dialog box that appears, notice that the text is      

set to use the default link  style. 

6. Click the Edit Link Styles button to open the Layout tab of the Site Properties dialog box. 

7. Use this interface to specify how text links will display on the site. For this site project, the link states are set to inherit any bold or italic styles 

applied to the text, but will never be underlined for any of the states. The text colors are set for each state: 

Normal: Light Brown 

Hover:  Brown 

Visited: Light Brown 

Active: Brown 

Note:  Use the Resolution menu to choose between output for Standard and HiDPI (2x) – to set the quality of images published or exported from      

the site. The HiDPI setting requires you to place images at twice the dimensions but displays optimally on retina displays and other high definition 

screens. 

 
 

8. Click OK to close the Site Properties dialog   box. 

9. Save the site and close the Gallery page in Design    view. 

 
 

Adding and configuring a Fullscreen Slideshow widget 

 

The Gallery-fullscreen page contains a Fullscreen Slideshow widget that will load when the visitor clicks the link from the main Gallery page. 

1. Open  the Gallery-fullscreen page  in Design view. 

2. Choose View > Hide Guides if  desired. 

3. Open the Widgets Library and expand the Slideshow section. Drag a Fullscreen slideshow to the page. 

Notice that the widget immediately expands to fill 100% width of the    page. 

4. While the slideshow is selected, position the top edge along the bottom edge of the header, so that none of the browser’s background fill        

color shows through. In this design, the slideshow doesn’t display a close button — visitors click one of the links in the top menu to jump to a    

new page and leave the  slideshow. 

5. Click the blue arrow button to open the Options panel and apply the following settings (see Figure 58): 

New Hero: Fill Frame Proportionately 

New Thumbnail: Fill Frame Proportionately 

Transition: Fade 

Transition speed: .5 seconds 
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Autoplay enabled, set to begin playing in 3 seconds 

Resume After: Disabled 

Play Once: Disabled 

Shuffle: Disabled 

Enable Swipe: Enabled 

 
Layout 

Lightbox: Disabled 

Free Form Thumbnails: Disabled 

Full Screen: Enabled 

 
Parts 

First: Disabled 

Next: Enabled 

Previous: Enabled 

Last: Disabled 

Captions: Enabled 

Counter: Disabled 

Close Button: Disabled 

Thumbnails: Disabled 

 
Editing 

Show Lightbox parts while editing: Enabled 

Edit Together: Enabl 

Figure 58. Update the settings to configure the slideshow in the Options panel. 
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6. Click the Add Images folder. In the Import dialog box that appears, select the following files: gallery-1.jpg, gallery-2.jpg, gallery-3.jpg, gallery-  

4.jpg, gallery-5.jpg, gallery-6.jpg, gallery-7.jpg, and gallery-8.jpg. Click Open to import the 8 image files and close the Import dialog box. 

7. Click anywhere else on the page to close the Options    panel. 

8. Click Preview to see the in-progress slideshow. The 8 images you added are displayed when you click the Next or Previous buttons. Also, if    

you wait for 3 seconds, the auto play feature starts playing the slideshow, and it continues to loop. Notice that the default slideshow image       

has been  removed automatically. 

9. Click Design to continue editing the Fullscreen Slideshow   widget. 

10. Select the Previous arrow button and position it to the center left side of the page. Drag the Next arrow button to the center right side of the 

page, aligned horizontally with the Previous button. And then, drag the Caption window down to the bottom, so it is centered and about 40  

pixels from the bottom edge. 

Note:  If you are having difficulties seeing the entire page, set the Zoom Level to 75% so that you can view the entire slideshow in Design mode. 

 

 
1. Set the fill color of both of the Next and Previous buttons to Light Brown. 

2. Use the Text tool to select the arrows inside the Next and Previous buttons. Apply the subhead style, and then set the alignment to center, 

leading to 100%, Space After to 0, and color to   White. 

3. Leave the Caption fill color to White, but lower the opacity to 77. Select the placeholder text caption and apply the subhead style. Then, set     

the Space After to  0. 

4. The first caption displays placeholder text while the cup of coffee is displayed. Click the caption again to select the text inside it. Replace the 

placeholder caption text  with: 

 
Latté with fresh-ground espresso topped with premium chocolate  shavings 

 
5. Click the Next button to see the next slide with the lemonade and the bowl of lemons. Replace the caption text with: 

 
The Pink Lady with fresh-squeezed lemonade and a dash of cranberry  juice 

6. Update  the remaining captions  using the corresponding  descriptions: 

 
Chocolate-Cinnamon Swizzle Sticks available for every hot beverage 

Marshmallow Crisp Bars and Puffed Wheat Bars made fresh every morning 

Seasonal Maple Walnut Cupcakes 

Tart yet sweet Lemon Meringue Pie with fresh lemon juice and lemon zest 

Katie's Café relies on the freshest organic ingredients purchased daily 

Grilled Cheese with Rye Bread accompanies our home-made Gazpacho  soup 

7. Choose File > Preview Site in Browser to see the finished slideshow. Watch it auto play, or use the navigation buttons to jump to the next    

and previous image, while the descriptive captions display on each slide (see Figure 59). 
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Figure 59. The  FullScreen Slideshow widget displays to the edges  of the browser   window. 

 
 

 
18. Click the Gallery menu item to visit the Gallery page. Remember to always offer visitors a way to leave a Fullscreen Slideshow widget, when   

they want to return to the rest of the site. Roll over the link: VIEW GALLERY FULLSCREEN and see how the color changes on Hover and         

on Mouse Down, based on the default link    style settings. 

19. Return  to Adobe Muse and close the Gallery-fullscreen page  in Design   mode. 

 

 
 

Formatting text at the top of the Blog page 

 

The Blog page displays a descriptive header above an embedded Tumblr blog page. 

1. Open the Blog page in Design   mode. 

2. If the guides are not already showing, choose View > Show Guides. 

3. Create a text frame and type: KATIE’S BLOG. Apply the header paragraph style. 

4. Drag a copy of the Page Separator from the Library   panel. 

5. Use the Selection tool to center the two elements vertically on the page (see Figure 60). 
 

Figure 60. Center the page title and the page separator on the page below the header. 

 
 
 

Using embedded HTML to display a blog on a Muse  site 

 

Embedded HTML refers to the source code generated by a third-party  website, such as Google  Maps, YouTube, SoundCloud, Flickr, or Picasa.  

You can set up accounts with these websites, log in, and then copy the embed code from their site and add it to your site. 

When you paste embedded HTML into a page, it's like putting a window inside a page on your site that displays the content of a third-party site 

inside it. 

Embedded HTML is a great way to add complex information (such as maps, weather forecasts, stock market quotes) as well as rich media (like 

digital videos, slideshows, and audio files) quickly and   easily. 

https://www.google.com/maps/
http://www.youtube.com/
https://soundcloud.com/
https://www.flickr.com/
http://picasa.google.com/
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To add a blog to the Blog page, you’ll copy the source code generated by Tumblr.com. The free online service lets you log in and post blog entries 

that are publicly available. Blogs are easy to use and are helpful when you want to make it easy for someone who is not technical to update their 

own site. Most blog sites include an online interface, so you can use any browser to log into your account and post new entries, without any HTML 

knowledge or additional   software. 

Note:  Visitors don’t need a Tumblr account to view blogs embedded on a page. You need an account to generate the code while designing the   

site, and to log in to add blog   posts. 

 
 

1. It is not necessary to create a Tumblr account to follow along. Copy the code below (generated by the Tumblr website after creating a free 

blog): 

<iframe src="http://katiessf.tumblr.com/" width="916" height="3500" marginwidth="0" marginheight="0" frameborder="no" scrolling="no" 

style="border:0px;"></iframe> 

 
 

2. In Plan mode, double-click the Blog page thumbnail to open the page in Design mode. 

3. Click in the middle of the empty Blog page and select Object > Insert HTML. Click inside the field of the Edit HTML window that appears     

and paste the content. Click OK to close the Edit HTML window. 

 
After embedding the HTML code, you'll see a blue bounding box with handles surrounding the blog posts that were entered for the Katie's  

Cafe Tumblr account. 

4. Use the Selection tool to drag the handles to center the blog content on the page. A dark blue alignment guide indicates when the selected 

object is centered vertically (see Figure   61). 

Figure 61. Position the Tumblr blog to center it on the Blog    page. 

 
 

 
That's all that is required to embed HTML into Muse pages. If you ever want to edit the HTML code, you can right-click on an embedded HTML 

element and choose Edit HTML from the context menu that appears. This opens the Edit HTML window so that you can access the code you   

pasted earlier (see Figure  62). 

https://www.tumblr.com/
http://katiessf.tumblr.com/
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Figure 62. To access and edit the embed source code, open the Edit HTML window. 

 
 

 
6. Choose File > Preview Page in Browser to see the Blog page display in a new browser window. 

Notice that as you scroll down the list of blog entries, the brown header displays above the blog page content. This behavior occurs because the 

header is in the Interior master page, and content in master pages displays in front by default. 

Now that you've explored how you to add embedded HTML to display a Tumblr blog, continue on to Chapter 6 to learn how to add an interactive 

Google Map to the Contact page. After adding a Contact Form widget to the Contact page, you’ll see how to add a favicon and publish the trial      

site. 
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Chapter 6 – Adding Form Widget – Styling appearance –publish site 
 

 

Using embedded HTML to display a Google map 

Adding  and configuring a simple contact form  widget 

Configuring the settings for the entire Simple Contact Form widget 

Configuring  the settings for individual  form elements 

Styling the appearance of the Contact form fields 

Styling the appearance of  the Submit  button 

Testing the form and retrieving the submitted messages 

Styling the addresses  listed on  the Contact page 

Using the built-in Spell Checker and updating the dictionary 

Adding a favicon  in the Site Properties  panel 

Creating a free trial to publish the   site 

 

 
In Chapter 5 of Building your first website with Muse, you learned how you can link to anchor tags to jump to sections of a long page. You also     

created and styled a Fullscreen Slideshow widget. In this next part, you’ll see how to add an interactive Google Map using embedded HTML. Then  

you’ll work with a Contact Form widget to build out the Contact page. And finally, you’ll apply the finishing touches by adding a favicon and then       

you’ll publish the completed trial  site. 

 
   

Using embedded HTML to display a Google map 

 

Google Maps is a free service—you simply provide the address (or addresses) and click the Create Map button after logging in to your account.       

Enter a title and description and then click the Embed button. Copy the HTML code provided in the field labeled: Paste HTML to embed in website. 

1. In Plan mode, double-click the Contact page thumbnail to open it in Design mode. 

2. Copy the source code below, which was generated by the Google Maps site: 

 
<iframe width="100%" height="400" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps/ms? 

ie=UTF8&amp;hl=en&amp;msa=0&amp;msid=218302982680021663941.00049fcd9cf93276f540e&amp;ll=37.7737,- 

122.43782&amp;spn=0.067844,0.098877&amp;z=12&amp;output=embed"> 

</iframe> 

 

 
You can create a custom map to one or more addresses. In this example, the map displays pointers for each of the three Katie’s Café locations in    

San Francisco. 

3. Paste the code near the top of the Contact page. Use the Selection tool to position the embedded HTML to center it on the page, so that the      

top portion of the map displays underneath the header area    (see Figure 63). 

Figure 63. Paste the Google Map embed code and position it on the page below the header. 

http://maps.google.com/maps/ms
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4. Use the Text tool to drag a text frame below the embedded map and type Contact. 

5. Apply the heading style to the text   frame. 

6. Create another text frame below the page title. Copy the following text and paste it into the text frame: 

While each of our bakeries embodies the unique attributes of its neighborhood, they are all bound together by Katie's impeccable attention to 

detail, commitment to service, and, above all, enjoyment of good    food. 

7. Apply the body style and align the text frame to the left side of the page. 

8. Option/Alt-drag a copy of the text frame and align it to the right side of the page. Select the text and replace it with this content: attention to 

detail, commitment to service, and, above all, enjoyment of good    food. 

9. Use the Selection tool to select both the left and right paragraphs and choose Object > Group. 

10. Drag a copy of the Page Separator from the Library   panel. 

11. Use the Selection tool to center the three elements (header text, group of two text columns, and page separator graphic) to align them 

vertically on the  page. 

12. Choose File > Preview Page in Browser to see how the in-progress Contact page appears in a browser (see Figure 64). 
 

Figure 64. The  finished Contact page  includes a fully functional Google   map. 

 
 

 
The embedded HTML Google map is interactive. Click the arrows to pan around the map and click the plus (+) and minus (-) buttons to zoom in     

and out. 

13. Close the browser and return to Muse to continue editing the    page. 

 

 
Slideshows can also be added directly to pages, but in this example, you'll nest a Thumbnails Slideshow widget inside the content area of a 

Tabbed Panel widget. Follow these   steps: 

1. While editing the about page in Design view, click the Gallery tab to see the content area container with the placeholder content displayed 

below it. 

2. Select the placeholder content (the image frame and the text frame inside the content area) and delete it. 

3. Open the Widgets Library and expand the Slideshows section. Select the Thumbnails Slideshow widget from the list and drag a copy of it to     

the page (see Figure  59). 

 
 

Adding and configuring a simple contact form widget 

 

Next, you’ll add a contact form to the Contact page to make it easy for visitors to send messages using the website. 

1. Continue editing the Contact page in Design   mode. 

2. In the Widgets Library, expand the Forms section. Select the Simple Contact Form widget and drag it to the right side of the Contact page, 
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below the page separator (see Figure   65). 
 

Figure 65. Drag the Simple Contact form to the    page. 

 
 

 
3. Use the Selection tool to position the form on the right side of the page. 

 

 
 

Configuring the settings for the entire Simple Contact Form widget 

 

Update the settings for the Contact Form widget to control how it functions. 

1. While the entire form is selected, the Selection Indicator displays the word: Form and indicates the form is currently displaying its Normal 

state. 

2. The Normal link is a menu with four possible states, just like menu items or buttons (see Figure 66): 

Normal 

Submit in Progress 

Submit Success 

Submit Error 

Figure 66. The States menu displays the states for the entire form. 
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When you want to adjust the form as it appears in various states, you can select the corresponding state name from this menu or the States panel. 

For example, if you select the Submit Error state, you'll see the form update to display the error message. While the Submit Error state is selected,     

you can adjust the appearance of the error message. For example, you could change the text content or switch the error text color from red to         

blue. 

3. While the entire Form is still selected on the Normal state, click the blue arrow to access the Options Menu. In the Email To field, enter your  

email address. Leave all other default settings (see    Figure 67). 

Figure 67. The Options menu  displays the settings for the entire  contact    form. 

 
 

 
Take a moment to familiarize yourself with the available    options 

 
Note: If you'd like the form submissions to forward to multiple email addresses, you can enter the addresses (separated by semicolons) in the 

Email  To field. 

 

In the After Sending menu, you can choose between two options: 

Stay on the current page (the default   behavior) 

Choose a different page (or a linked file) to display after the form submission 

The example site only uses the three default form fields, but notice that you can add other fields by enabling them in the Options panel.   

The list of other standard fields  include: 

Cell Phone Number 

Home Phone Number 

Home Address 

BC CAPTCHA 

Company 

Work Phone Number 

Work Address 

Website 

If you want to add one of these fields, simply select the checkbox. 

You can also add custom fields with Single Line Text and Multiline Text options. 

Click the plus (+) button next to the custom field you'd like to add, and then enter the label in the Design view to describe the new form field 

element you are adding to the  form. 

 
 

Configuring the settings for individual form elements 

 

As you select form elements, the Selection Indicator displays the element's name, such as Label, Text Input, or Submit. Check the Selection 

Indicator frequently to see which nested  element in the form is currently   selected. 
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1. Click the entire form once to select it, and then click the Name field again. First the Selection Indicator displays Form, then Form Field. 

2. When a Form Field, Label, or Text Input form element is selected and you click the blue arrow button to access the Options menu, the options 

provided offer settings specifically related to that element. For this site, make sure Require Entry and Show Prompt Text When Empty options 

are enabled, and disable the Label and Message Text options (see Figure 68). 

Figure 68. The Options menu displays a contextual set of options for the selected form element. 

 
Note: Require Entry means that an error message will display and the form will not submit if the visitor attempts to submit the form without 

entering content in the  field. 

 
 

3. Repeat step 2 to configure the Email form field the same way as the Name field. 

4. Update the Message form field. This time, the only option that should be enabled is Show Prompt Text when Empty. 

After making these changes, the text labels above each field are no longer displayed. 

 

Styling the appearance of the Contact form fields 

 

While a form element and a specific state are selected, you can use the Fill panel or the Control panel to adjust its appearance. 

1. Select the Name form field and click the States menu near the Selection Indicator (see Figure 69). 

The states of the form fields  are: 

Empty 

Non Empty 

Rollover 

Focus 

Error 

Figure 69. Access the list of states available to each form element. 
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2. Click the field once again, to select the Text Input (this refers to the type of field). While the Empty state is selected, set the field’s fill color to  

none, the stroke color to Brown and the stroke    weight to 1. 

3. Click again inside the Name field to select the text. Use the Text tool to replace the default Enter Name text with: NAME. 

4. Apply the subhead serif paragraph style, and then reset the font to Gentium Book Basic and set the Left Indent value to 7. 

5. Repeat steps 2-4 to style the Empty state for the Email and Message form fields. 

6. Select the Name field again. This time choose the Non Empty State. Set the field’s fill color to white and notice that the other states 

automatically update. 

7. Repeat step 6 to style the Non Empty state for the Email and Message form fields. 

8. Update the Email field text to EMAIL and update the message text to: HOW CAN WE HELP YOU? 

 

 

Styling the appearance of the Submit button 

 

Next, you’ll set the fill and text formatting options for the Submit button. 

1. Select the Submit button and choose the Normal state in the States menu. The states of a Submit button are displayed with the Submit 

button is selected. The states of a Submit button   are: 

Normal 

Rollover 

Mouse Down 

Submit in Progress 

2. While the Normal state is selected, set the button’s fill color to Light Brown. 

3. Select the Rollover state and set the fill color to Brown. Notice that all of the other states update automatically. 

4. Choose the Normal state again for the Submit Button. Use the Text tool to select the text and update it to: SEND MESSAGE. You can resize     

the width of the button as  needed. 

5. Apply the subhead style, and then set the alignment to center, set the Space After to 0, and set the color to White. Notice that all of the other 

states update to use the same formatting for the    text. 

In this example, all states of the Submit button display white text, but notice that you could choose a different state while the Submit button is 

selected to apply a different  style. 

The Contact Form widget is now   complete. 

 

 
 

Testing the form and retrieving the submitted messages 

 

After configuring and styling your form, be sure to save the site. Later when you publish the site, you can test the form in a browser to check that it        

is  functioning correctly. 

1. Visit the page with the contact form and interact with it on the live site. Attempt to submit the form without entering content in the required 

fields. Test how the form functions and pay close attention to how it displays error messages. 

2. Once you have determined that the form works and displays as expected, try submitting the form with a test message. Check your email 

account and verify that you received the message in your    inbox. 

 
 

Styling the addresses listed on the Contact page 

 

Follow these steps to add the three Katie’s Café addresses to the left of the contact form. 

1. Use the Text tool to draw out a text frame on the right side of the page. Copy and paste (or type) the following: 

 
KATIE'S CAFE NOE VALLEY 

123 ELIZABETH STREET 

 
Monday - Friday 06:00 - 22:00 
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Saturday - Sunday 07:00 - 22:00 

2. Select the top two lines and apply the subhead style. Then, set the size to 16 and the Space After to 0. 

3. Select the remaining text (days and hours) and apply the body style. 

4. Option/Alt-drag a copy of the paragraph down. Replace the text content with this: 

 
KATIE'S CAFE COLE VALLEY 

301 CARMEL STREET 

 
Monday - Friday 07:00 - 22:00 

Saturday - Sunday 09:00 - 22:00 

5. Duplicate the second text frame to create a third address. Replace the text content with this: 

 
KATIE'S CAFE LAUREL HIEGHTS 

800 SPRUCE STREET 

 
Monday - Friday 05:00 - 22:00 

Saturday - Sunday 07:00 - 22:00 

6. Use the Selection tool to align all three text frames along the left side of the page, and position them so that there is an equal amount of 

space (approximately 30 pixels) between each   one. 

 
 

Using the built-in Spell Checker and updating the dictionary 

 

Adobe Muse includes a Spell  Checker  that makes it easy to locate and resolve  misspellings in text frames. The  Spell  Checker  is  always enabled.    

It displays a red underline on any words not found in its dictionary. For example, the misspelled word HIEGHTS is underlined in the third text frame   

(see Figure 70). 

Figure 70. Misspelled  words are underlined in  red. 

 
 

 
1. To fix the typo, use the Text tool to select the word (double-click to select it), and then right-click to see a list of suggested words displayed. 

2. If one of the suggested words is correct, press the Down arrow or click the suggested word you'd like to use, and then press Return/Enter to  

apply it. If you make a mistake and choose the wrong word, simply undo the change (Edit > Undo) and then choose a different suggested       

word or edit the word using the Text tool. In this case, choose the correct spelling: HEIGHTS. 
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If a word flagged as a typo is used only once (such as a person's name or location) and you know that it is spelled correctly, there is no need to fix        

it. The red underline you see in Design mode is not displayed when you preview, publish, or export a site. 

When working with commonly used words, such as business names or addresses, you can add the words to the Spell Checker dictionary so that    

they are not marked as  typos. 

Use the Text tool to right-click on a word you want to add to the dictionary, and then choose the Add to Dictionary option from the context menu     

that appears. 

You can set the desired language (which in turn sets the Spell Checker language dictionary) for the entire site and for individual text frames. 

To set the Spell Checker dictionary for the entire site, choose File > Site Properties. Click the Content tab, choose the desired language in the 

Language menu, and then click OK (see Figure   71). 

Figure 71. Set the language for the entire site in the Site Properties dialog box. 

 
 

 
Sometimes site projects require providing text in multiple languages. In these cases, you can set the default language (used most often) in the Site 

Properties and then set the Spell Checker language for specific text frames that display text in a different language. 

To set the Spell Checker dictionary for a text frame, select a text frame with the Selection tool. Right-click and choose Language > (Choose 

desired language) in the context menu that appears (see    Figure 72). 
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Figure 72. Set the language for a selected text frame in the context menu. 

 
 

 
The site design is now finished for all pages. In the remaining sections of this tutorial, you'll see how to add the final touches and publish the site       

as a free trial. 

 
  

Adding a favicon in the Site Properties panel 

 

A favicon is a small, square image that you create, add to a site, and upload to personalize bookmarks and URLs. The favicon is generally        

displayed in the browser's address bar. Many browsers also display it next to a page's name when it is bookmarked, or in a tab that contains a       

loaded site page. Use any image-editing program, such as Photoshop or Illustrator, to create a square (equally proportioned) image file to use as a 

favicon file. 

 

Follow these steps to add a favicon to the   site: 

1. Choose File  > Site Properties. The  Site  Properties panel appears. 

2. In the Layout tab, click the folder icon to the right of the Favicon section. Use the Choose Favicon Image dialog box that appears to browse        

to the sample files folder and select the file named favicon.png (see Figure 73). 
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Figure 73. Set  the favicon.png file in the Site   Properties. 

 
 

 
3. Click Open to select the file and close the Choose Favicon Image dialog box. Then, click OK to close the Site Properties dialog box. 

4. Choose File > Preview Site in Browser. Look at the top of the browser window to see the favicon displayed in the address bar. If the site   

loaded in a tab, you may also see it displayed there. Experiment with bookmarking the page, to see how the icon displays next to the page 

name in the list of  bookmarks. 

Now that the site is finalized, the next step involves uploading the site to the provided Adobe hosting servers. 

 

 
Creating a free trial to publish the site 

 

After you've finished designing your site, the next step is to publish the site. When you first launched Muse, you entered an Adobe ID to sign in.    

Use the same user name and password to publish all of your Muse sites. 

1. Click the Publish link at the top of the Control panel. The Publish panel appears that enables you to enter a site name and choose the 

temporary  URL  (see Figure 74). 

Figure 74. Enter the site name and URL that you want to use for your trial site. 

 
 

 
2. Click OK to begin the publishing   process. 

It may take a few minutes to upload the files to the remote server. When the site is finished uploading, the site's home page displays in a new 

browser window. 
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3. Click the links in the top-level site navigation to visit the pages and interact with the widgets. Review all of the pages and make sure the 

elements display as expected. Make notes of any issues to be    fixed. 

4. When you are finished, close the browser and    return to Muse. 

The Publish panel has updated to display an OK button and a Manage link, which you can click when you are ready to push the site live (which 

involves starting the paid hosting plan, setting up a custom domain name to access the site, and adding users). 

Your published site will use a URL similar to the one below. You'll use this address to access the pages in a browser and share the live site with 

others: 

http://my-new-website.businesscatalyst.com 

Once the trial site is published, copy the URL in the address bar and send the link to your clients, so that they can review the live version of the    

site. Clients can review the design, test the interactive features in a browser, and approve the working example of the pages. 

After your clients or colleagues review the trial site, they may request changes. 

If you want to update an existing trial site, you can open the .muse file and continue editing the pages. When the updates are finished, click 

Publish again. 

This time, if you want to overwrite the existing trial site with the new changes, choose: Upload: Only modified files. 

If you choose to update the new content, always visit the updated live site and double-check that the changes you made work and display as 

expected. 

To learn more about publishing    your trial site, see Publishing Websites. 

 

 
 

 

http://my-new-website.businesscatalyst.com/
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User manual for the Norfac Dynamo scripts 

 

The Dynamo files which can be downloaded from the Norfac Web-page are 

included in 2 zip-files: 

1. Norfac_Dynamo-Definitions.zip 

 

This file contains the individual Dynamo scripts. The file must be copied 

to the folder C:\users\”username”\Appdata\Roaming\Dynamo\Dynamo 

Revit\1.3\definitions. “username” is the name of the user for which the 

scripts should be accessible. 

For other versions of Dynamo the folder may be different, refer to Dyna-

mobim.org for further information. 

 

The included files are: 

 

Norfac_2017_1.3.2_GenericPHPPtoExcel.dyf 

Norfac_2017_1.3.2_SpecialityPHPPtoExcel.dyf 

Norfac_2017_1.3.2_WallPHPPtoExcel.dyf 

Norfac_2017_1.3.2_WindowPHPPtoExcel.dyf 

Norfac_2017_1.3.2_PHPPExport.dyf 

Norfac_2017_1.3.2a_DoorPHPPtoExcel.dyf 

 

Each of the files is a Dynamo script to handle a specific category of 

families. They can be used as templates for extending the number of 

parameters to be extracted by the script.  

 

2. Norfac_Dynamo-Project.zip 

 

This file contains the main dynamo script Norfac_2017_Final.dyn which 

is the file to be loaded from within Revit. This file can be copied to any 

location on the harddrive. 

In addition it contains a template for the shared parameters used in the 

script files; Norfac_PHPP.txt. This file can also be copied to any loca-

tion on the harddrive. 
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To use the Norfac_scripts first make sure a revit file is open and the pa-

rameters have been setup as needed. 

Then use the tab on the panel called “Add-ins” for Revit versions prior 

to release 2017 and “Manage” for more recent Revit versions. Press the 

button “Dynamo” see fig. 1 

 

 

 

 

 

 

 

 

 

 

 

 

 

                               Figure 1  Load Dynamo from the Manage tab 

 

Then select “Open” from the Dynamo menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                  Figure 2  Select “Open” from the Dynamo menu 
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Browse to the folder where the file Norfac_2017_Final.dyn was installed 

and select the file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                Figure 3  Browse to select dynamo file to run 

 

After selecting the file the main screen of Norfac Dynamo script will ap-

pear and look like in fig. 4 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                Figure 4  The main screen for Norfac Dynamo 
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Select the “Browse” command in the top most node and browse to the 

folder where the excel-file to hold the extracted data should be placed. 

After the selection of the file press “Run” at the lower left corner. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                  Figure 5  Browse to folder where to place the results. 

The script will now run and extract all the information described in the 

scripts and send them to the excel sheet. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                  Figure 6  The data presented in the excel sheet 
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To modify the individual scripts, first right click on the main node and 

select “Edit Custom Node” from the menu. 

 

 

                Figure 7  Right click and select to edit custom node. 

The main node will open up and there is now access to the individual 

nodes for each type of Revit category that data should be extracted 

from. 

 

 

 

 

 

 

 

 

 

 

 

 

 

                 Figure 8  Individual nodes for categories 
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Right click on the node to be analysed or modified and select “Edit Cus-

tom Node”. The node will open up and the basic structure of the node 

will be accessible for modification. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                 Figure 9  Individual node exploded for modification 

 

For modification of the individual nodes, modify the category and the 

parameters for extraction. 

 

 

 

 

 

 

 

 

 

 

                 Figure 10  Areas for modification of the category and parameters. 
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For the Norfac script to work properly the families must have attached 

the required parameters with respect to type and instance as given in 

the script. The parameters must have values assigned to the parame-

ters. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

             Figure 11  Parameters assigned for a Norfac wall type. PHPP ticked to show this element is included in data exctraction. 

 

Type parameters must have their values set to appear in the extraction. 

 

 

                 Figure 12  Norfac U-Value parameter set for wall element 
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